Interval gaps caused by settings or hardware? Please help

Hi I have recently developed an issue I am unsure of what has changed. I have gotten into doing rotary work with my Om Tech 80w black and red with Ruida controller started so using a home built roller setup which I quickly outgrew and replaced.

The setup I started with was a Nema 17 motor and I quickly realized the existing stepper driver which controls a dual shaft Nema 23 Y axis was cooking the Nema 17. So I adjusted the stepper DIP switches to lower the current as much as possible. This helped my overheating issues but I didn’t want to have to flip switches every time I use my rotary so long story short I ended up buying an OmTech rotary setup which uses a Nema 23.

I didn’t have an issue with the Nema 17 setup, there were no gaps and it did what I expected, no issues with interval but now after trying a Otur chuck style and now OmTech Nema 23 rotary I am now seeing these gaps in my rotary engravings.

I followed a YouTube video that had me change some machine settings such as idle speed and homing speed so the rotary would stop spitting my cup out of the rotary because the travel speeds where way too high. I have loaded my default machine settings best as I can tell and still have these issues.

I have also set the DIP switches back to stock. I think they are anyways.

It’s late and I’ll have to think on this… but I got started…

You seem to have seen enough rotary time and you didn’t mention that the machine was operating in any different than normal manner… so we’ll throw out a couple items…

With a factory lens, a 0.10mm dot is about the best most of these can expect… that’s everything right on…

There appears to be exposure of the stainless substantially less often than I’d expect for a 0.10mm scan rate.

Leads me to believe something might be loose… If you zoom in, you can see where it looks like multiple lines are formed, but only a couple passes make it through…

  1. check mechanical
    a. head/lens/tubes/nozzle - ensure none of them have any kind of ability to move
  2. basic setup, with all three — they work
    a. working tube
    b. clean and aligned optics
    c. proper focus

I have both kinds, the wheeled is a PiBurn 3.

Wheel rotaries are touchy and can slip/slide around… I have machine setting for specific rotaries, chuck and wheel… I can accelerate much quicker with the chuck… but you can still toss mugs into next week…

Good luck


Thanks for the suggestions jkwilborn, I have made sure there are no loose mechanical pieces. The problem I feel is in the software settings or in the driver. The way that the stepper moves is strange, it ratchets forward like it takes a micro step forward, pauses, waits for the x to make a pass or two then takes either a full step forward and starts so over again. It’s not a linear movement like I would expect which is why I don’t know how to determine if its software or a stepper driver issue. I am attaching links to videos which hopefully you can see what I’m taking about, the first video with the tape on the pulley shows this a little bit and the second video is when the setup was working decently using my OTUR chuck. Thanks in advance for any further assistance.

Are the stepper motors the same on both of the machines?

I’m at kind of a loss, I can see what you mean in the videos, but can’t suggest anything but double check that the fields are right… is it wired to the proper phases… If it’s two phase, then there is only a pair of wires/field.

Maybe @berainlb has a suggestions for you…


The Otur is a Nema 17 which has the same ratcheting type movement which is why I bought the 4 roller one thinking it might be an issue with the Otur. One thing I’ve been thinking about today is maybe the issue started when I tried calibrating the Y axis while using the rotary? Is that a bad practice and does it only apply to non rotary operations?

What I’m thinking is if I tried calibrating the Y axis while using the rotary, that maybe now my steps per mm for that axis are off and I don’t know what they should be because I think my stock machine settings were saved after trying to calibrate Y. Does anybody know what the stock steps per mm are for a red and black laser?

Any thoughts to the above?

The steps/rotation are determined by the setting of the motor driver. DSP don’t use steps/mm like some of the grbl processors use…

Here is a link on how to set up the rotary for your Ruida…

I you still have issues, sing out…


So I figured out what the problem was… Turns out it was a bad stepper motor that came with the cheap Vevor 4 wheel rotary I bought from Amazon. I swapped in the Nema 23i had from my scratch built chuck rotary and the ottoman went away! That’s again for the suggestions

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.