IP of machine if I know my IP

I can look up my IP online, but when I input the IP (even changing the last number set) and finish the setup it will not connect. Mind you I am using a USB to ethernet adaptor. Trying to find out if this cures my USB cable issues.

So how do I look up IP on the machine?

Default for Ruida controllers is

If you push the Z/U button on the controller you can scroll though the options to “IP config” and see or change the IP address.

Thank you!

Still not connecting, set gateway and reconfiged setup for a second laser essentially…just a different mode. Not sure if this adapter is the issue or not, got the one suggested.

When you say you are looking your IP up online, I’m assuming that you are using a browser to go to some site that is showing you your IP address. This however will not work when trying to hook up your laser. Your computer will have an internal non-internet routable address on it, that is being translated to a public routeable address by your internet gateway. If you are running windows, you can open a command window and run ipconfig to show the internal private address of your machine. THIS is the segment that you will want to configure your laser into in order to be able to connect with it.


Yes sir that is what I did, it just won’t talk to the computer via that usb/ethernet adapter apparently. So back to thumb drive I suppose.

Just for clarity, do you have the ethernet cable connected from the laser directly to the usb/ethernet adaptor plugged into your computer?

Or are they both plugged into a router?

Ethernet to adapter to usb on computer.

Ok. That’s the problem. The usb/eth adapter doesn’t have the correct IP address type, unless you set it manually. What kind of computer are you using? Mac, Windows, Linux?

Windows, no switches on adapter that I noticed. I will look again, or are you talking software in windows?

Open a command prompt (click the start button, then type “cmd” (no quotes) and press enter). Then type “ipconfig” (again, no quotes) like @sutick mentioned in his above post. You will have a list of network adapters on your system with their IP addresses. One of them will be the wifi adapter that is connected to your router for internet access. Take note of that one. If it is 192.168.1.xxx, then you will have to change the IP address on the Ruida. If it is anything else like 192.168.0.xxx or 10.10.10.xxx or 172.16.xxx.xxx, we should be fine to go to the next step. Post a screen shot of the command prompt window if you are unsure.

There should be a loopback adapter that we don’t care about, and then the USB-eth adapter that will have an IP that looks like 169.254.xxx.xxx. That’s the one we will change in the next step.

I had put in (and still have) the Ruida set to the default gateway of this default gateway

Oh Ya, the ruida IP address is

Is there another “Ethernet Adapter” above the top one listed in that window? On the USB-eth adapter are there lights on it?

Also, is there any way to directly plug the laser ethernet cable into your router? Or is it to far away?

Took a full size screenshot, the adapter is plugged in

I would have to buy a much longer cable and don’t want that stretching through house.

It looks like either the driver for the usb-eth adaptor is not installed, the adapter is bad, or the cable is wrong/bad. If it was correctly connected and installed, there would be an adapter listed that has an IP address of 169.254.xxx.xxx.

Just a shot in the dark but it’s possible that the adapter you are using is a 10/100 adapter and my guess is that the Ruida controller has a 10/100 adapter, not a gigabit adapter. This means that unless you are using what’s called a crossover ethernet cable, it won’t link between the two machines. If either or both have 10/100/1000 (gigabit) network adapters, then it would link with a standard ethernet cable. Most usb-eth adapters have two lights built into the network jack. If neither of them are on, then you have a physical connection problem that needs to be addressed before continuing.

It must be the cable as the adapter tries to talk to it when I first tell it to connect to the laser. Then the light goes steady which means according to TP-Link that it is not connected but tried to.

Well, if the light is on, that’s a good thing. That means that physically the cable is good. If there were no lights, there would be a problem. The weird part is that all of the adapters in your ipconfig output say media disconnected, which to me seems like the drivers for your usb-eth adapter aren’t loaded.

Right click on the windows start button and go to device manager. Expand the “Network adapters” tree if it isn’t already. Is your TP-Link adapter listed? Does it have a red X or yellow ! symbol on it?

Yes, the TP-Link is green and says operating properly…it is 10/100/1000 adapter. I am just guessing this isn’t gonna work with my laptop.