Issues Opening File from Inkscape


(Aaron Miller) #1

I’m having some issues with opening a file that I made in Inkscape. I tried searching here and through google with little luck, it may be that I’m not using the right terms and that’s the reason I’m not having much luck. Using Inkscape version 0.92.4 and using the trial version for Lightburn. The file I made in Inkscape only comes out as a line drawing, not as the filled in shapes I am using. I saw a mention on another persons post about needing to use the Geometric Bounding box, so I set that and then redrew from scratch and getting the same issue. I’m not sure where to go next with this. The picture shows side by side what it looks like in Inkscape and what it looks like in LB. Any help is appreciated, as I imagine I’m missing something minor that is causing my issue.

Thanks,

Aaron


(Hank Morgan) #2

You have all your layers set to line. Change your layers of choice to “Fill” and you’re there.


(Oz) #3

LightBurn generally operates in “wireframe” mode, which is what you’re looking at. Set any of your colors to “Fill” then run a preview (Alt-P or the toolbar button in the top center that looks like a computer monitor).


(fred ungewitter) #4

Using Fill in Inkscape can be misleading with respect to that which will be imported in LightBurn. It’s safer to use the fill feature in Inkscape to get an indication of how you wish your work to appear, but as Oz suggests, the Preview feature of LightBurn is the only real reference.

You may discover that you have broken shapes in LightBurn that would not otherwise appear in Inkscape.


(Aaron Miller) #5

To all who responded, thank you. I overlooked that setting in Lightburn and have spent the last few days trying to figure out what I was doing wrong in Inkscape. Oh well, good learning experience.


(Oz) #6

LightBurn defaults to wireframe view because otherwise it’s impossible to see the difference between two overlapping shapes and two “properly intersected” shapes. I’ll explain. Look at this image:
image

The two circles above, in LightBurn, are just circles, and both are set to fill. In a normal paint program, and in LightBurn’s filled view, the red fill overlaps the black fill, and masks it. Most laser software, including LightBurn, will burn the black circle first, then the red one, and the area where they intersect will burn twice. You can only see that they intersect if you’re looking at the wireframe view:
image

Or the preview:
image

The “proper” way to design this, assuming the overlap isn’t intentional, is to completely remove the area of the red shape from the black shape, like this:
image

More visible here with them moved apart slightly:
image