J tech laser on a xcarve Z axis does not work

I’m a new user of LightBurn software. I purchased a J tech laser and mounted it on my Xcarve.
I haven’t been able to figure out why I can’t get the Z axis to move when using the control panel in LightBurn. The Y and X work use fine but the Z does not move either u or down. Any help would be appreciated.

What settings for Z control do you have enabled?

I’m not sure I have any. I’ll have to look at that
James. Which ones should I ? I guess I assumed that if the x y worked the z would also.

Your assumption is correct. Z does work…, if you have one and it is configured correctly. :slight_smile:

This will depend entirely on what you have and how you have things set up. You are asking for assistance in understanding your hardware system which I can’t do for you. You have not identified the controller and firmware you are using nor how you have it set, so I am at a loss.

Not trying to be difficult, but you have made “assumptions” and present as if we should know what you have and just work. You need to share more when asking for help with your setup. It is, after all, a Do It Yourself system and we can’t see what you have done yourself.

There are many posts from a good group of JTech/XCarve users here that I find are willing to help as well. Have you tried using the search in the upper-right?

In our First Time User post, you will find a good resource for your setup.

1 Like

Your right I should have giving you more information on my controller.
I did look into the search area first. I purchased an X carve machine last January and
purchased the J-tech 7watt laser for the machine along with Lightburn Software in December 2019. I’m running the software on a mac with high Sierra 10.13.6. I use an x-controller to running the cnc and laser. The Z control seems to be the only area I can’t get to work in Lightburn. I have enable the Z axis and relative Z moves only with no change. I have watch the setup videos and have read through the J tech set up procedures. Do have any thoughts Craig

Can you get the Z-axis to respond correctly with the software that came with this setup? Checking this would help us identify if it is a hardware/wiring issue or software related/configuration issue.

When I use the Easel software that came with the Xcarve X Y Z works as it should.

Turn off ‘Continuous Jog’ - it doesn’t work for Z moves because we don’t have UI yet to enter the range of allowable Z values.

Do you mean relative Z moves only ? - I do not see a ‘Continuous Jog’ setting

It’s here, if enabled:


It must not be enabled because I do not have that on my screen

Which version of LightBurn are you running? Check Edit > Device Settings and make sure $J jogging is disabled (and make sure you have the option to disable it - if you don’t, you likely need to update)

I checked and $J is disabled

I just download LightBurn this week

What happens if you just enter a gcode command into the console to move the Z? Like, G1 Z5 F100 ?

LightBurn isn’t written specifically for any type of controller or system. Easel was written for XCarve systems, so it can make lots of assumptions about what you have, but we can’t.

Some new code went in recently for jogging gcode controllers, and it may have affected Z jogging on some systems, so I’ll need to look into that, but if you don’t see an option in the device settings to enable $J jogging, or that option is off, you shouldn’t be affected.

I entered the code and the Z axis moved down. I had to hit the emergency stop to stop it

On the x controller

What does LightBurn report for Z when you click ‘Get Positions’? You might have Z in negative space.

looks like everything is at zero

… and where was the actual machine when you did that? As in, what was the physical position of the laser head when it reported zeros? Where was the Z?