JOB interrupted: Numeric value format is not valid or missing an expected value

I’m new here and quite new to the CNC/Laser and Lightburn world.
I’ve been successfully using this Genmitsu 3018 PROver for drilling and now I’m experimenting with the laser burning of painted PCB board for etching. However I must admit that I’m just pretty stuck.

I’m running Lightburn 1.2.00 on a Debian system and went through all the guides on how to setup the machine, the workspace and found several really great youtube channels/videos on this topic too…
I’m doing some testing to get the best combination between layers of paint and type of laser burning but I just seem not to be able to find a pattern on how and when Lightburn simply stop a job at random stages.
I’ve re run the same job twice and it stopped at two different points, which makes me wonder how this error can even be consistent or existing in first place (in the GCODE) as indicated by Lightburn:

Pretty common problem lots of people are having, although in my case the laser doesn’t actually stop firing, but just the CNC machine stops moving and the error comes out.

Numeric value format is not valid or missing an expected value.
On or near line 12118:
Job halted

Here are the Gcode (saved from Lightburn)'s lines around 12118, where Lightburn claims there’s a problem:
G1 X0.494S1000
G1 X0.1S0
G1 Y0.075S0
G1 X-0.1S0
G1 X-0.494S1000
G1 X-2.173S0
G1 X-2.166S1000
G1 X-3.364S0
G1 X-0.52S1000 (this is line 12118)
G1 X-0.742S0
G1 X-6.046S1000


Here’s my current config:

here’s the messages at software boot up:
Waiting for connection…
Grbl 1.1f [‘$’ for help]
Target buffer size found

I can upload my working file and some photos of the corrupted job/PCB once I figure out how on here.

I tried different USB cable/ports with no success (hence this post), I’ve googled for days and I just couldn’t find a reason why this job would fail.

Any insight is very welcome, because I’m not going to keep wasting PCB on this and I’d love to bring my hobbyist project forward. Thanks you!

I’ve just re run one same job and it stopped again at a random position.
What I’ve changed this time was the GRBL transfer from Buffered to Syncrounous and now I get a different log status when it breaks:

Stream completed in 41:44
Grbl 1.1f [‘$’ for help]

it stopped again with the laser ON.

Any insight is really appreciated. Thanks.


Looks like you’re experiencing a communication issue.

The most common causes:

  1. bad usb cable or bad usb port
  2. static discharge from laser operation running down to usb port and resetting the port; make sure your laser is properly bonded and ground
  3. bad usb hub
  4. OS timeout for usb ports
  5. bad power supply
  6. electrical noise on outlet circuit (e.g. other machine starting on the same circuit)

There is another user on a different topic that seems to get a similar issue only on certain files and only on Linux. Same file, same computer, running Windows doesn’t occur. I’ve never seen that before so I don’t assume that’s what’s happening to you but something to be aware of.

1 Like

Hey Thanks for your reply.
Yeah I’ve tried various USB cable, and using different USB ports from my computer, but so far without any tangible difference.
When I tried again yesterday and it failed I was very careful not even to use my computer to avoid any interference, and nothing else in the house was being switched on/off. I’ll double check the connection and grounding of the CNC, however I just would like to understand whether this is an official support channel and whether there’s any debug log I can provide/retrieve to get more information about what’s going wrong when job get interrupted.

Re the Linux/Windows, I have two laptop and one is runnning Windows, so I could give that a test, however my main workstation is a Debian machine and I’d really need/like to get this one working.

The design I’m trying to laser burn I’ve re traced various types and it just doesn’t seem to follow any specific pattern on when/if the job will fail.


This is an official community forum where LightBurn stuff also participate. You can reach official support through email at

There are logs and support data that can be generated. You may want to reach out to support to see what may be of value but that’s generally going to be more valuable under crash scenarios. I suspect in your case LightBurn isn’t failing.

If it were an issue related to static then images or other engraving operations (in contrast to cutting operations) would be more likely to trigger the condition.

Thank you @berainlb for your help, really appreciated, I’ll get in touch with Support.

Thing is, in my case, it seems different from other cases where the laser stops firing, in my case is the motors that stops (with the above errors in console) whilst the Laser keeps firing in the stopped position, and I couldn’t really find any other post/google result showing the same kind of failure. Meh.

This is actually fairly common. I think what happens in that scenario is that the laser stops taking any commands. The laser was firing at the time of connection breakage. Since there are no new motion commands the motors stop while the laser continues.

As far as other devices on the same circuit… watch out for fans, pumps, vacuums… really anything that could cause interference or a voltage drop.

Updated to eh latest version 1.2.01 in hope something would improve, nothing running in the house causing power surges, not a single device changed any power state, tried every USB port and USB cable I have in the house (including the one that comes with the Gemitsu, which NEVER failed with any drilling job, ever).

Yet another uncompleted job after less than 60 minutes in. And, btw, this job was a drilling job before I tried to switch to Lightburn for Laser engraving instead… so I’M SURE it has been successful.
Lightburn simply doesn’t work here. And I might sound a bit ranty here, (I apolgize for this) but its quite crazy that the only piece of software I’ve spent money on (I happily run many open source software on my Debian system) is the one that gave me 100% failure rate.

Time to contact support I guess.

LightBurn in most likelihood has nothing to do with the issue which is why an upgrade would not affect this. Try this:

  1. Save gcode from LB and try running in your CNC software
  2. Save CNC drilling gcode and run in LightBurn.

I suspect the first case will fail and the second case will work. If not, then perhaps something LB related but cases like this where LB does end up being the root cause is extremely rare.

There was one case where one user had issues with LB in Linux but not Windows which was odd. No conclusion on that case from what I remember.

Can you confirm that you checked the laser for proper bonding and grounding?

1 Like

The connections for the laser module are as per instruction manuals, now sure what else to try other than sampling with oscilloscope/multimeter GND and VCC on the board and the laser board.

Many machines comes factory shipped with grounding issues. Ortur went through a whole retrofit program to address disconnects caused by static discharge. You can apply the same lessons to your machine.

Ortur – Ortur Laser Master Grounding – Ortur

The one area that may be suspect is the bonding of the laser module to the chassis since many configurations only include the 3-pin (V, Gnd, PWM) cable and nothing else. And if you’re not getting issues on the CNC configuration then seems the laser module may be the primary culprit. Although normally I would think that the wheels and belts would be the primary source of static buildup.

If you’re getting this issue more with fill or image operations as compared to line operations then this is an indicator that static discharge is the culprit.

One thing you could test for if you have the equipment is that you’re getting reliable power to the unit.

Separately, what is the wattage of your laser module and spindle? How are they getting power?

1 Like

the amount of patience and helpful information you’re passing this way is truly amazing.
This last post just re-equalized the frustration accumulated from this day (this laser engraver ain’t the main reason :slight_smile: ) and I thank you so much for this.

Yes all what you say up here makes quite a lot of sense. (and thank you so much for the Ortur link!)
I’ll give it a great read and it seems I have a weekend ahead full of tests and machine testing/checking.

Let me say, though, that the error code we get back should be able to detect some failure on the machine side, even if that’s a disconnection. How is it possible this is not getting reported properly then? Why would the error message “blame the GCODE” then? And also, I’m now guessing that the GCODE line its blames its actually the GCODE line where the job gets interrupted, which could possibly mean there’s space for job resuming … hmm … that should make sense.

Anyway, thank you so much. I won’t be able to put my head fully on this for a little while, work is taking over these weeks, but any update I can gather by testing around during my breaks from work will definitely be reported here, the least I can do is keeping you updated on how things are turning thanks to your help! :slight_smile:


In typical disconnect issues there’s no message at all from what I remember. I think the short just puts both the USB port and the controller in a funky state and is no longer processing or able to respond. That puts your controller in a slightly different state than I’m used to seeing.

It’s possible that with the USB short that gcode is no longer being buffered to the controller midstream and thus showing up as a gcode issue rather than a specific disconnect issue.

Good luck on your future troubleshooting.

oh btw I always forgot to answer to your question earlier.
my laser is a 5.5mW module for the 3018 PROver Gemitsu (Sainsmart)

this is my kit, basically:

Right now I’m running the GCODE saved for my job from Lightburn, loaded into Candle and running it straight away without tweaking/changing a thing… Its my usual 6 hours test job which I’ve never got to see past 1 hours.

Laser is lasering… I’ll send an update here either when it crashes, or at job completed.

hey just a quick question, according to this video when static buildup/grounding problems occur you should see garbage in your console… which is not happening in my case. What are you thoughts on this?


This is more a situation of “you may see”. From what I recall I don’t think even the majority of reports indicate this occurring. From memory the types of situations I’ve seen:

  1. nothing of note in Console
  2. Console will indicate something about poorly formed gcode
  3. garbage in Console
  4. Reboot indication

I don’t want to jinx it … but I’m getting quite excited to see the laser still burning that black paint from my PCB and not failing after 3hrs+ … like I said. this is now ruinning a GCODE from Lightburn into Candle1.2b …

If this job wont fail I rekon such grounding and static buildup could still be part of the issue, but what about how Lightburn is handling this then?
I must admit I’m actually, and intentionally, doing things like using this machine (where Candle/Gemitsu machine is attached), I’ve been turning on/off all sort of devices attached to the same power line/wall socket, been even launching Lightburn to see whether another software querying the USB in use would cause some interference…
nothing. This is still running. (Again, I hope I didn’t just jinxed it).

Will keep this updated :slight_smile:

If this finishes with Candle and this is known to never finish in Lightburn then I think focusing on LightBurn would be the most sensible.

Can you take a screenshot of Edit->Device Settings?

1 Like

Yup, here.
the screenshot is wide large so you can see the type of job I’m talking about, or at least a glimpse of it and layers.

This job is the same I’ve been trying over and over in Lightburn and failed without exception, and always in random points but with the same Error:2…

… and its still running in Candle :slight_smile: (actually I can’t wait to finally etch this board later today, unless it fails before then)