Job Origin and Start Position "Current Position" and Framing

I am running into two strange problems. No matter which point I select on the Job Origin, the laser starts in the lower left corner. Also, when I hit the Frame button (no matter what the shape) the laser module jumps about 1 mm in some direction, not sure because it’s too fast. Then it frames the drawing. I’m talking simple frames like a 1" square or a 1" circle. The settings are currently:

$$
$0=64
$1=193
$2=0
$3=2
$4=0
$5=0
$6=0
$10=0
$11=0.010
$12=0.002
$13=0
$20=0
$21=1
$22=1
$23=35
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=1
$100=800.000
$101=800.000
$102=800.000
$110=2000.000
$111=2000.000
$112=600.000
$120=1000.000
$121=1000.000
$122=10.000
$130=254.000
$131=154.000
$132=100.000
ok
Thank you,
Bob
image

The lower left corner of what exactly? I assume you’re talking about the lower left corner of the entire laser frame? It should begin where the location of the green square is on the workspace, but relative to your work. It won’t be in an absolute position.

Also, keep in mind what job origin means. I suspect you think it means that you expect the laser to start burning on that spot. What it actually means is the origin or anchor point from which the burn operation is located. This is to help with alignment of the job so if it’s easier to align the job at center of the overall burn, or bottom left vs upper right, etc.

You can change the speed of these traversal moves by changing the speed designated in the Move window.

You see the initial move because the laser head needs to move to the outer perimeter of the burn area from the current position. I can’t recall if framing starts from job origin but it’s a similar idea. Current position does not mean start burning from this point. It represents the position from which job origin will apply.

I guess I’m not being to clear on my problem description. I’ve attached two images to try to clarify what I’m asking.
image
image
I make a simple 1" square, I select “Current Position” to start from in the lower left corner of the 1" Square. It works fine when it Frames the square but it does jump 1mm on both the X and Y Axis. (I did adjust the Feed Rate in the Move window from 1000 mm/min down to 100 mm/min and that made no difference in the jump). Then I selected the upper right corner of the 9 dots and the frame acted like it was still starting from the lower left corner. I tried the center dot, I tried the upper left dot and the lower right dot. The frame always starts at the lower left dot as if the controller doesn’t see the position change at all. I’ve been messing around with this laser set up for close to a year now and never ever ran in to this problem before. I also never had the 1 mm jump before. I can only relate it to the two new updates in the recent weeks. Does any of this make sense?

it’s odd that you’d get no change in behavior at all for the different job origins. I can think of 1 reason for the 1mm jump. The feedrate wouldn’t affect whether or not the jump happened, just ths speed at which it’s happening.

Can you provide the following:

  1. Screenshot of Device Settings
  2. Run these commands in Console one a time and return results:
$#
?
  1. Save 3 copies of gcode while job origin is in lower left, center, and upper right. You’ll need to save as .txt file in order to post here.

I have had this issue when I move the laser with my hand to the desired job origin.
It does not happen when I use the manual move command before i frame.

To clarify it does happen sometimes on the first motorized move after a “hand” move, so after i do a “hand” move I click the move key in LightBurn to move it 0.5 mm right then left (or whatever) and check if it is in same spot it should be. I fine adjust with the LightBurn buttons if not.
In my case it is good from then on.

1 Like

Here are the results of your requested suggestions.

2022-03-09 1511

Framing at Lower Left Job Origin for a 1" square (by the way - there was no 1 mm jump)

$#
[G54:-6451.600,-3911.600,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok

?
<Idle|WPos:6262.100,3809.400,-1.000|FS:0,0|Ov:100,100,100>
ok

Framing at Center Job Origin for a 1" square (this time it jumped at the start and at the end - whenever I mentioned it jumped,
I should have been more clear, it always was jumping at the start and at the finish)

$#
[G54:-6451.600,-3911.600,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok
?
<Idle|WPos:6262.100,3809.400,-1.000|FS:0,0|Ov:100,100,100>
ok

Framing at the Top Right Job Origin for a 1" square (Jumped 1 mm again at the start and finish)

$#
[G54:-6451.600,-3911.600,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok
?
<Idle|WPos:6262.100,3809.400,-1.000|FS:0,0|Ov:100,100,100>
ok

Another peculiar thing. In the Device Settings, I have “Auto Home on Startup” turned on but the laser is not going home. However, if I press the “Home” button, the laser will go Home to the front left.

There are a few things to unpack here…

You’ve got an unusual offset configured. I assume this is unintentional. This shouldn’t affect your operation using current position but is distracting.

You can clear this by issuing:

G10 L2 P1 X0 Y0

Can you confirm if you have limit switches installed on your laser?
Also, your laser is configured to home on startup ($22=1). Does it do this?
If you do not have homing switches you should disable “Auto-home on startup”.

What are the coordinates in “Get position” in Move window after you press Home and it’s at rest. Can you do this before removing the offset from above?

This would make sense because the center of the job is not at any point of the square. So it would travel from center to start of burn area… finish the square, then go back to center.

Also, I wasn’t clear enough in my instructions.

What I wanted you to do for the 3 job positions was to press the “Save Gcode” button in the Laser window. Do that for each of the 3 positions. Make sure the extension is set to .txt in the saved files and post them here.

In regards to the offset, the only offset I did was at some point I did the instructions given in LB’s documentation regarding negative workspace and entered (from pg 74) If your machine uses negative workspace coordinates you’ll need to apply a workspace offset
(G10 L2 P1 xx yy). I entered -254 and -154 respectively. I’ll undo this after I get the “Get Position” coordinates for you.

Yes, I have limit switches.

No, it doesn’t go home on startup.

Got you. You were right to have the initial offset configured. Somewhere along the way it got “corrupted” it looks like. Reset to what you had initially:

G10 L2 P1 X-254 Y-154

You have a switch also on Z axis?

This is odd. It’s possible that your firmware was compiled without this ability but seems odd if true.

When you push the home button does it actually activate the homing switches? It should first hit Z, then X and Y in either order.

Ok, Prior to hitting the Home button:
X: 250.961 Y:150.341 Z: -0.955
After hitting the Home button:
X: 244.039 Y: 147.976 Z: -0.039

I hope I didn’t waste your time so far. I should mention when I did the 3 Framing Runs and posted the $# and ? data, I did not have the Laser turned on. I was just doing those runs without the laser powered up. I then was poking around and ran the tests again with the laser turned on and got some different results such as: I got good burns on the four outer corners (meaning the laser started from the correct points) but not any of the other points. If I did the center position, the laser started at the lower left, if I did the center top position, the laser started at the upper right. I’ll rerun those test you asked for with the laser on. My personal opinion is it shouldn’t matter if the laser is powered on or off. It should still start the frame from the selected Job Origin. What do you think? I’ll get back to you with those tests.

Yes, I have 6 limit switches. X axis right and left, Y axis front and back and Z axis top and bottom.

Yes, it first activates the Z axis on top and backs off about 6 mm and then it travels to the left and front and hits the two limit switches and backs off about 6 mm.

Here are the 3 saved files.
Center Job Origin Frame with laser powered on.txt (276 Bytes)
Lower left Job Origin Frame with laser powered on.txt (260 Bytes)
Upper Right Job Origin Frame with laser powered on.txt (260 Bytes)

Let me know if you need anything else.

Thanks for the response Aaron. This machine is doing weird things all of a sudden and I’m at a loss. It seems it hasn’t been doing this consistently but when it does it again, I’ll try your suggestion. I’ll let you know after I finish up with berainlb. Thanks again, Bob

When you save gcode it won’t run the laser at all so no problem there.

This is expected. Center means you’re placing the job from the center position. But it will need to move to the first position that needs engraving.

This could be possible depending on where the cut plan is determined to start the cut.

Ok. Interesting. So both actual homing and safety limit switches. Can you confirm that they all function as expected?

Ok. That sounds right. Curious why it doesn’t do this automatically or on demand. It may have something to do with the safety limit switches.

I’m reviewing your 3 gcode examples. I don’t see anything wrong with them.

Let me annotate an abbreviated version.

Center job:

G0 X0.5Y-0.5 - move from center position half inch right and half inch down
; Layer Labels
G1 X-1S400F15.748 - start burning and move left 1 inch
G1 Y1 - keep burning and move up one inch
G1 X1 - keep burning and move right one inch
G1 Y-1 - keep burning and move down one inch
G1 S0 - stop burning
; return to starting pos
G0 X-0.5Y0.5 - go back to "current position"

Lower-left job:

G0 X-0Y0 - move from center position 0 inches left and 0 inches vertically (ie no movement)
; Layer Labels
G1 Y1S400F15.748 - start burning and move 1 inch up
G1 X1 - keep burning and move 1 inch right
G1 Y-1 - keep burning and move 1 inch down
G1 X-1 - keep burning and move 1 inch left
G1 S0 - stop burning
; return to starting pos
G0 X0Y0 - return to "current position"

Upper-right job:

G0 X0Y0 - move from center position 0 inches horizontally and 0 inches vertically (ie no movement)
; Layer Labels
G1 Y-1S400F15.748  - start burning and move 1 inch down
G1 X-1 - keep burning and move 1 inch left
G1 Y1 - keep burning and move 1 inch up
G1 X1 - keep burning and move 1 inch right
G1 S0 - stop burning
; return to starting pos
G0 X0Y0 - return to "current position"

All-in. I don’t see anything wrong with the code. How would you expect it to work differently? Or is it not doing what I’ve annotated?

I guess I didn’t make myself clear. When I click the center dot in the Job Origin block. The laser does not traverse 0.5" on the Y and does not traverse 0.5" on the X. The laser just goes X 1.0" then Y 1.0" then X - 1.0" then Y-1.0" and stops. It does not traverse back to the center position.

That looks great but that’s not what happens. The laser does not start out in the center of the 1" square and travel 1/2" in any direction. It just starts at the position the laser is in and does the 1" to the right, 1" up, 1" left and 1" down and stops. It does not start at the center or stop at the center of the 1" square. If I run the job by pressing start, the laser does the same thing but goes to the left 1" and up 1" and right 1" and down 1". This is the opposite of the Frame function.