Job starts from Ruida origin setting rather than 'Current position' in LB

I’m only a newbie to LB and still getting to grips with the software and a newly installed ruida controller.
Any jobs we run from our controller start from the origin position set on the controller.
When we send a file from LB to the controller with “Start from ‘Current position’ selected” the machine moves to the origin position before starting even when we have the head in a different location.

Currently we move the head to a new start position and press origin on the keypad then run the job.
On start up the machine returns to home as normal, then moves to the origin, I presume this is normal and very handy when running repeat jobs.

Have I overlooked a setting somewhere in LB or on the controller? TIA

‘Currrent Position’ mode should always run from wherever you have the controller sitting, not the user origin, when you start a job. Can you tell me which model of Ruida controller you have? (or show a picture of the keypad)

Hi Oz,
Thanks for the speedy reply. The controller is a RDC 6445.

There is a setting in the controller menus called ‘Multi-origin’ mode. Check to see if you have that enabled, as I’ve seen that cause issues before. If that’s not it, I can get mine set up and see if I can reproduce this.

@Grumpy_Old_Man - You have a 6445, correct? Have you noticed anything odd with ‘Current Position’ mode?

From memory I’m 99% sure that ‘Multi Origin’ mode isn’t selected. I’ll try enabling that option tomorrow when I’m at the machine.

Thanks Oz

No, make sure it’s off, not on. :slight_smile:

I sold the laser with the 6445. Only have a 6442 now.

Hi Oz,
The ‘Multi Origin’ wasn’t selected. Tried working with the ‘return para’ but I’m still having the same issue ??

Which version of LightBurn are you using?

Hi Oz,
Version 0.9.14

I have the 6445 and it starts from the current position when I select that

1 Like

Even though you have Multi Origin Enable deactivated, check that start origin is set to 0:

I also find it helpful to have Return set to Absolute Origin:

Thanks @Stroonzo for the post, I’ll check that ‘Start Origin’ is at 0, I have a feeling that it is.
I’ve already tried each of the options on the return page, it’s set at ‘absolute origin’.

The controller has just recently been fitted and we’ve only used LB with it, I might try installing RD Works to see if I get a different result. I’ve tried using an earlier LB version 9.11 but it hasn’t made a difference.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.