Job stops while in progress

Although intermittent, I can recreate this problem at will. If I browse the internet using a browser while a log job is running, the job in progress will stop. The timer will continue to countdown. I’m running a Mac running Mojave 10.3.6 and using the repleo USB-serial driver. I initially thought that was the problem - it’s an older MacBook Air that needed replaced anyway - so I replaced it. Bought a new (used) computer with an nice 4 core i5 and put 16G RAM and a big 500G SSD. Loaded Ubuntu 20 on it - and it’s really fast. Put Lightburn on, no issues, it even detected my GRBL setup (the MacBook Air didn’t) running a job, seems effortless for it. Then… while browsing the web, the job will stop. So two computers, different operating systems - same error. Does anyone else have similar experiences?

Thank you!

I had a similar issue from forgetting to disable limit switches. It was randomly triggering.

I see this was addressed via email as well so I post that response here:

Oz: "We have about 25,000 users at this point, roughly half of whom are using gcode systems. If running a browser was enough to kill a job in progress, I’d be hearing about it, but you’re the first person to mention anything of the sort. I’d be very surprised to find that it’s LightBurn causing the issue.

A simple test would be to run a different piece of software, like LaserGRBL (running in buffered mode, so the streaming is the same). Save the GCode from LightBurn and send it using LaserGRBL. If that software pauses mid job as well, then it’s not a software problem."

disabling the limit switches in the software? I took them off my frame.

Yes, your reply was why I thought I would check with more population. If it’s a one off - then I need help and if not, then you need help.

Have you run the suggested test to confirm? Please post you results.

it would be a 2 off - two different operating systems on two different computers. It could be my hardware, which would be a bummer, and a bit odd since it will run for hours if I don’t start a browser.

Just want to confirm you also set the $ option to turn the limit switches off when you removed them physically.

I didn’t - let me look up which one it is and turn that off

Yes, $5 = 0 - so they were already disabled.

1 Like

Have you tried this test? What was the result?

I’ve not run the test yet - that will take me a while.

It’s windows - I don’t have any windows computers

ok - not just isolated to browsers - doesn’t matter what’s going on - could be nothing. And the job will stop. It also happens with both systems - the mac or the new ubuntu computer.

watching the console - the commands being sent stop. I don’t know if that helps.

I’d recommend going through:

sadly not Windows - it’s two systems, Mac & Ubuntu.

What is the result of the rest of the suggested testing, which has nothing to do with the OS running? How is the connection on the controller side? Are these known-good components?

I had a spare controller - sainsmart - was able to upload grbl 1.1h to it - and it seems to be running without issues, so far. The stopping during job runs had increased exponentially, so I suspected it was the eleksmana card - I don’t know why - and maybe that wasn’t the whole issue - but it seems to be running now. I’ll give everyone an update in the next few days. I really appreciate all the help and support!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.