Jog control Y axis is reverse

The Jog control for Y axis is reverse in respect to LCD controller table UI.
The Up button should move the platform to the back. Currently it is moving toward the front.
I can not find the option on Machine setting to reverse it. Can this option to be added.

Do you also have a situation where burns come out flipped? If so, this is likely caused by incorrect Origin definition in Device Settings. If currently top-left, move to bottom-left, or vice versa. Same approach if on the right side.

Note that this also flips the design. Any designs done previously will need to be flipped.

1 Like

The LightBurn UI controls the direction of the laser head relative to the project. If you push the left arrow and the laser moves left, then pressing the up arrow should make the laser move to the rear of the project to be consistent. The platform would move the opposite direction to achieve that.

This is due to work coordinate and machine coordinate are different on Snapmaker.
The machine coordinate (0,0) is located on rear left. While working coordinate (0,0) is located on front left.
All you need to do is go to device and select origin to front left. You image should be print correctly.
With this setup the Y axis jog controller is reverse. This is why I ask for the option to reverse it.

I understand that. It just that Snapmaker UI does the opposite. That is why is this request and not a bug.

This would “break” the current design paradigm. LightBurn jogging moves the relative position of the laser head, not the platform. What would you expect to happen to left-right movements?

X and Z axis are correct. Only the Y axis is the “issue”.

Suggest you go to the feature request page and see if a request for this already exists and up-vote it or create a new one.

What model number is the snapmaker? I want to see if the Bed moves in the Y direction.

If the head moves as instructed it will move in the direction of the arrows when called. If the bed moves it will move the opposite direction so the head travels the correct direction with respect to the bed.

I have a 3018 made by a different manufacturer and this is expected behaviour. It still confuses me from time to time though.

I have A350.
The bed movement is correct in respect to working coordinate (FL).
However, Snapmake’s table UI is respect to machine coordinate (RL).
I just want LB to have option to switch the Y direction so that UI will be same between LB and Snapmaker.

I think you’re looking for this switch.

You may be better off changing the location of the Origin in Device settings:

I already look. It is not on my machine setting. :disappointed:

it’s hiding. go to the last line in Machine Settings. Do you see
… > Outputs Setup

Click that line so the > turns into a V and shows the warning and the rest of the codes. :slight_smile: