JOG with PC joystick


I can’t seem to find the settings, where i could setup a PC joystick to jog.

I found some one years old topic that asked the same question, and i red there that it will be implemented…

If i was still on windows, i might start writing some code send button click commands to LightBurn, but i am on Linux now and my coding knowledge is not deep enough to tackle this. If there are keys mapped to the jog panel, please let me know, i think i can manage to do a joysitck → keypress in sw or hw.

Best would be of course to have the jog controls available via a PC controller (gamepad / joystick)

thank you for your time,

I thought this will be a bit more popular topic…

Anyhow, just to test it, i hooked up a game controller to the PC, and then installed a program called AntiMicroX that lets you generate key presses and mouse movement based on the controller’s buttons pressed.
It is a royal pain to use since it can’t do absolute coordinates, but i managed to make it work if i position LightBurn’s Move window accordingly.
This is more hustle than worth though…

I was waiting to see where this thread was going, and am very interested. Although not un-usable, a bit of a pain constantly changing the unit sizes to move the head around. (I do not have a ruida control, so only can use the lightburn screen)

So, I am following this

I left a feature request on the AntiMicroX github ‘forum’, if it gets implemented then it will be easier to use.

On second thought, i think i might try to write a program that accomplish the JOG functions with a connected controller. I’ll also make my own control box, already ordered the joystick and the USB interface chip on eBay. The program will be compatible with regular gamepads though :slight_smile:

Of course native joystick support would be the best…

You can use the ‘Click to move’ feature to position the laser anywhere:


If you have a controller that supports continuous jogging, that doesn’t require constantly changing the distance value. Number pad arrows also jog the laser.

Well, on my PC, on the current version of LightBurn, the number pad arrows do NOT jog the laser.
I have the Linux version of the software.

The ‘Click to move’ feature is not relevant when we are looking for a way to use a gamepad/joystick to control the machine.

Yeah, keyboard arrows don’t work for me in Linux Mint.

Which version of Linux? The Linux version is bizarrely different across different versions of the OS, likely because of different underlying system libraries.


I have Xubuntu 20.04 LTE. If JOG and maybe basic controls could be assigned a key (like in OpenBuilds CONTROL), then the joystick interface could be easily done via third party programs, or we could write our own (i’m looking into that, but this will be my very first program for Linux, so i’m not there yet)

I tried it on Windows, same behavior. That is, the numpad buttons don’t JOG. Interestingly all other shortcuts like Ctrl+=, etc. work as intended.

I found something though:
IF the Cuts/Layers or the Console window is selected, and i click between the windows to the right and the work area at the left (so the focus is not on anything), then i press any numpad buttons (up/down/left/right), my machine starts to move the head diagonally, so i click stop so it doesn’t crash.
This came up in the console window:
Grbl 1.1g [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]
Starting stream
Stream completed in 0:01
Reset while in motion. Grbl cannot guarantee position. Lost steps are likely. Re-homing is highly recommended.
[MSG:Pgm End]

Would you like to explain to me what a joystick can be used for in LightBurn? Thanks

The PC is at one side of the room, the laser is at the other.
Ran USB cable from PC to laser, where both the controller and the joystick is plugged in.
Then when i put in or move a tiny work-piece, can use the joy to JOG the head and the laser dot at the proper starting point. Maybe start and stop the cut with buttons on the controller. The point is, this would be a great solution for those who have the controlling PC farther away.
Probably i’d prefer a solid physical joystick over clicking on the screen anyways, so i can look at the machine head while controlling it.

Thanks for the explanation


While i would still like to have the feature of connecting a PC gamepad to do the JOG in LightBurn, i decided to give it a try and write a program that can do this.
The test version is ready, please keep in mind that this is my very first Linux program.
It works like this:
-reads the joystick
-jumps to fixed coordinates and presses the left mouse button
It has it’s limitations, for example lightburn has to be full screen (so the coordinates of the jog buttons are known) and the move window has to be the active one (this can be ‘fixed’ if i make the mouse jump to the ‘Move’ tab and click it for every gamepad button press)

Now while this can do what i want, all i have to do is start the program and make lightburn full screen, then i can jog away with a gamepad, it would be really nice to have this feature built in…

The numpad jog should work. Try this:

  • Go to Help > Enable Debug Logging
  • Click somewhere in the grid / edit window, to make sure it has the keyboard focus
  • Make sure Numlock is on
  • Press the keypad numbers, one at a time, from 1 to 9
  • Quit LightBurn

In your Documents folder you’ll find a file called LightBurnLog.txt - post it here.

did what you asked for.
First i tried to press just the number ‘6’ to jog right. Second try i pressed all the keys from 1-9.
In both cases the machine started to move the head to the lower left corner, both axis at the same time.
Since i have the limit switches at the other end, i had to abort by clicking on the STOP button.
First try:
LightBurnLog2.txt (1.8 KB)
Second try:
LightBurnLog.txt (1.8 KB)

my windows number pad does not jog the laser either.

You have a workspace offset programmed.

Type $# in the console and press enter, and notice that the G54 line isn’t zeros.

Then type: G10 L2 P1 X0 Y0 and press enter to zero it. Then try again.

Click in the edit window first, and make sure NumLock is on, then try again.

1 Like


THANK YOU! Now it works, could you elaborate a bit on what was wrong? I don’t remember programming anything regarding the workspace offset. Does this got entered to the GRBL controller maybe from another application, or is this a LightBurn thing?

Also, the numbers 1 and 3 move the head diagonally, instead of moving it up and down. Up and down works fine if i click on the JOG buttons.

1 Like