Jogging with numpad

GRBL & Diode machine

Does this only work when the machine has been either “Homed” or is setup to “Auto Home at Startup”?

I can jog my grbl based xcarve with 7w diode laser without homing.

Jogging with numpad was a somewhat recent feature addition, are you on the latest version of LightBurn?

Yes, I have v0.9.02 (grbl 1.1f)

Mouse clicking the arrows (move tab) are working as normal. Numpad arrows seem to be working in windows. Is there something I need to enable?

You need to have NumLock on, not off, so if the arrows are working in Windows, you have it off, and LightBurn can’t tell those arrows apart from the normal cursor arrows.

Tried it both ways, still doesn’t work. Could it be my KVM switch or this Logitech KB?

In windows numpad works as directional and it types out numbers (in notepad) so it seems like the KB is fine.

Well its working now, I unplugged the KB from the KVM and replugged it and now it is working… weird

7 posts were split to a new topic: Jogging with NumPad only moves one way

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.