K40 firing during fast moves

Just updated to Lightburn 0.9.02 and my k40 with C3D Mini (firmware 3-20-18) is now firing during fast moves while engraving as shown in the image. I uninstalled and reverted back to the last version I was using this morning 0.6.06 and everything is engraving as normal. The thin line through the top of the font is actually part of the font and supposed to be there.

Machine: k40 (came with digital controls & m2 nano)

Board: C3D Mini

Firmware: firmware c3d smoothie 4axis nomsd 3-20-18

gcode from v0.9.02: https://pastebin.com/dfhiSzPd
gcode from v0.6.06: https://pastebin.com/S8UGXE2T

Can you say whether you are using GRBL or Smoothie? It’s possible that you’ve set S0 to not be “off”, as the scanning code in LightBurn uses G1 moves with zero power during scan traversals so the movement speed is constant.

Hello, I edited the original post to include firmware version of Smoothie. I pastebin’ed the gcode files from both versions.

Yes, it’s as I said - the older version was using G0 for the moves in between scans, while the more recent versions use G1S0 moves between scans, to keep the speed consistent, which improves engraving quality.

What is your “laser_module_minimum_power” setting in the Smoothie config set to? It should be just below the firing threshold of the machine.

1 Like

It is 0.06 according to the config.txt I’ve not edited or changed this. How can I figure out the correct amount?

Trial and error, generally. The current number you have is 6% power, and it’s obviously still producing a decent amount of output there. You could probably drop to 0.03 as a starting point, and might still need to go lower.

The default C3D config has this as 0 actually.

1 Like

Thanks Oz & Ray, I will try 0.03 and 0.00 and see the results.