K40 homing in wrong spot

I moved my gantry by hand the other day as soon as I did that my k40 does not home correctly. Sometimes it home in the middle top or the upper left but every time I hit home it’s scoots to the right. I don’t understand gcode and I’m working on a job I need my laser to work. It’s always worked perfect until I moved it by hand now it doesn’t so I don’t think it’s a hardware issue. I used lightburn to move it to the home position and these are my coordinates. Sorry if this topic is covered but I don’t know gcode or what I would search for. Every time it does home it scoots tot he right progressively as you can see in the pic of some test burns.

I don’t follow exactly what it’s doing.

Does it homing switches?

If so, does it initially home properly, then move…


It won’t home in the upper left side just goes where it wants. If the job stops in the center of the work
Area and you hit home it just goes straight up to the top and stops. No job is repeatable either.

If it has limit switches, it’s continually seeing them or not seeing them.

When the console of Lightburn is open and you command a home cycle, does the controller have any complaints?


They are mechanical, it worked perfect until I moved the gantry by hand.

No error messages. But when I use the controller in lightburn to move it to the upper left corner the coordinates are negative.

If it was the gantry movement then it’s probably hardware. Steppers are generators if you apply power to the shaft, which you did.

I have a China Blue and I push the head all over the place, with power off, never had an issue.

Do the motor appear to work once it settles down… Can you move everything the correct direction via the software move?


Everything works perfect except I can’t repeat a job and it doesn’t home. When I say I can’t repeat a job because it homes different after each burn so it’s not consistent. I’m doing a huge job and really need it for coasters. I’m so

It’s clearly in the homing that it must be failing, since everything else works. It’s failing during the homing cycle. I don’t have a C3D board, so I haven’t fooled around with one.

I’d suggest checking the switches and wiring to ensure they are operational.

I can’t think of what you could have damaged by moving the head that would just effect the homing procedure, and everything else still working properly. That doesn’t seem logical…


I know I’m so frustrated. I checked all the wiring uninstalled and reinstalled lightburn paid for the upgrade looks like the coordinates need adjusted somehow because the coordinates in the upper left are negative instead of zero zero I just don’t understand all the tech stuff in lightburn to adjust it. That’s my theory anyway

It should home with or without Lightburn.

If you’ve check the limit switches and they are working you need to see why it’s goes negative.

I don’t know what else to tell you to check. All indications are it won’t home, but everything is working…? doesn’t sound right.

I don’t know the workings of that controller to help you out much further. I can’t image what you could have damaged (if you did) by moving the head.

Good luck…


I like lightburn is there anyway to actually get some
Help from them
Or just this forum and cross your fingers?? A new k40 is only like $300 but if I put the cohesion board from this machine in a new one is it the same issue?? Hate to throw this thing in the trash.

I think the problem is in your machine, not Lightburn. If it won’t home properly for you, then it’s not a Lightburn problem.

If the C3D board is failing, yes. It is not homing for some reason. Lightburn can’t fix a firmware/hardware issue.

If I’m following you correctly, I think the help you need is from cohesion. You have confirmed that the limit switches and wiring are working, if they work it points to the controller. If anyone has seen this, it’s them.

If the problem came up from moving it by hand, it would have to be the controller. I believe the C3D has ‘on board’ motor drivers. Don’t know how that could effect the homing, if they work properly elsewhere.

That would, at least, confirm/eliminate the controller.

The only thing I can think of that could result from Lightburn, is the controller you picked isn’t correct. But if it won’t home by itself that pretty much eliminates Lightburn.

Not all solutions involve one ‘fix’…

This thread has had 27 views, so people are following it. Usually that means they have nothing to ‘add’…

Good luck


I posted on cohesion to no response. So today I took a real close look at the limit switch. I noticed the bracket that holds the mirror had pierced the sheathing of the x limit switch causing it to short out. I’m wondering if this caused an issue on the board burning out the controller?? Thoughts?

1 Like

I counted on this as being true… :crazy_face:

I doubt it if it’s just mechanical switches. It will cause a homing problem but your CD3 board should have given you an error message. Did you ever look at the console to see if it’s telling you about a failure?

I seriously doubt you damaged anything by moving the head.

More like a coincidence with you moving the head.

Known to aviation and I’m sure everyplace else is a ‘fixation error’, you can’t find the problem because you are sure you know what the problem is, but it isn’t fixing the issue. This fixation causes you to ignore the facts or other information allowing you to solve the issue.

Generally it’s not real dangerous unless you are a doctor or a pilot where it can have deadly consequences.

I’m suspicious that’s your problem with ‘moving the head’… everything points to something other than that as being the issue. Lets forget about that until there is some evidence of damage.

Fix the wiring and lets go from there… :smile:


I ordered a new cohesion3d board and new limit switches. They should be in by the end of the week. I’ll put it all together and see what happens. Fingers crossed. I really hope this fixes the problem. I’m not getting any errors in the console. When I hit “home” it just says homing in the console. So maybe it’s not the board but I ordered one anyway.

Why do you suspect the board as being bad and not just the limit switches (or the wiring leading to the switches)?

Based on stated symptoms it seems to me the board is getting false positive about switch being activated due to the short. Board seems like it’s doing what it can with the information being provided it. But maybe I missed something.

I simply just don’t know about this stuff. It’s always just worked. I pulled wire out and it looks ok. I put the meter on the switch I have tone and when I push the switch the tone stops. That I think means the switch is good. My thought it being the board is that I would expect the machine to try an home and crash but it doesn’t. It just randomly picks a spot and calls it home like it’s lost. So I was suspecting it’s caused by the board. In all honesty I just don’t know it’s over my head. I just figured I’ll
Replace the switch if that don’t work I’ll throw the board in, if that don’t fix it I have no idea. I’m
Really just winging it. Your the only person who has really tried to help me. I’m desperate to get it working

Fair enough. If you replace everything it’s likely to work.

Try one thing, disconnect the limit switch wires at the controller. Does the laser head crash into the frame when homing? If so, then the issue is downstream from the controller (either wires or limit switches). Your test for the limit switch seems fine at first glance without knowing anything more about the switches so likely the wire itself.

Smoothieware I believe has a method for also displaying switch status but I forget how that’s checked.