K40 trying to cut way out of limits

New software user here and experiencing a little difficulty, with the limits of the work area. Software found my laser, I set the working limits of the bed. First few projects went fine. Later on in the day I designed a new project and the machine is now trying to cut way outside of working limits of the machine. None of my settings have changed and it seems that anything I try and cut are behaving the same way.

Any chance a part of your design was moved off the grid and therefore off the bed limits?

Design is perfectly aligned with the given x and y on the design space. It even frames correctly when commanded to frame. It only goes crazy when cutting or engraving.

try sending a file up here with a small project that you are having problems with

That screams environmental issue - either electronic or parts slipping, etc. Check all mechanical connections - stepper pinion gears, pinion to pinion belts, screws, shafts. Check earth on your machine between the grounds, the case and the centre pin of your power lead. Bad earth also causes screwy behaviour. Prolly got something loose.

I’ll check my ground when I return to the machine, I’m away for the next 10 days or so.

It could also just be slipping / missing steps if your settings are a bit too aggressive. You haven’t said what controller you’re using, how it’s configured, or what speed settings you’re using. These would help. We have a ‘Machines’ section in your profile that you should fill in with this info so people can just look to see what you have.

Running a cohesion 3D board, with the stock light burn speed settings. I definitely feel like it’s going to be some sort of software issue. Meaning something turned on that I’m not aware of that may have been mistakenly clicked. I’m not sure what to check, I have my laptop with me but I won’t be near the machine for a few days to check and see if the issue is resolved.

Well I’ve gotten back home, checked all my connections. Made sure the machine was grounded well. Pulled the SD card and changed the bed size slightly and now it seems to be worse then before I left. I’m about to plug my old board back in and see if it still has this issue.

Laser preforms absolutely fine with the old board installed using k40 whisper.

That’s a bit like saying, “when I replaced my car’s engine, the new one had issues. I put the old one back and everything is fine.”

That’s the expected outcome. You changed the entire brain of the machine, and haven’t adjusted or tuned anything. There’s a learning curve involved. Giving up and going back to the old board isn’t going to help you diagnose what’s wrong with the new one. When you have the new board back in and can run some simple tests, check to make sure you’re in ‘Absolute Coords’ mode, and try again.

If it’s still acting weird, describe how in as much detail as you can - “acting crazy and going all over the place” isn’t a description we can really act on. If you can record a video of the machine and post it to YouTube or DropBox and link that here, that could help.

I’m not sure what adjustments this requires but the laser board and software are advertised as a plug and play solution. I did however setup the software and SD card for the correct bed size… orientation and so on. It is in absolute coords mode. It acts like the machine doesn’t know where to cut when commanded. If you use the set laser position tool it will follow wherever you like correctly.
When trying to cut or engrave anything it automatically try’s to cut out of bounds on the left side facing the machine. Bed is set to 13X9… when I first installed the board it cut the first job without a hitch. Went to cut the second and that’s when this all started. Machine acts as if it doesn’t know where to cut. I will upload a video from earlier today… as I’m typing this it has developed a new problem and now says the laser is busy and will not do anything. I just find it extremely sketchy that I have to use any type of forum for the solution of an issue that makes the product unusable.https://youtu.be/D4cKgFN3M88

That sounds like it’s slipping like crazy when moving to the start point, then banging into the sides on the way back.

You say the bed is set to 13 x 9 - which would be about 330mm x 228mm. Did you set this in the config.txt file on the SD card, or just in LightBurn? (You’d need to set it on the controller - the setting in LightBurn is just to match the design space)

actually went into the SD card and changed it to 310x210 and changed it to suit on the Lightburn software also. its still trying to cut way off to the left side for some reason. also changed the speed to 1200 instead of 2400 trying to stop the slipping.

Then it’s most likely trying accelerate too fast for the current being supplied to the motors. In the config file are two lines : alpha_current and beta_current. I think the defaults are 0.4 and 0.6 (this is in amps). Try bumping them up to 0.6 and 0.8 respectively and see if that behaves better.

changed the current values and the machine still seems to have a mind of its own when cutting. just out go curiosity what lights should be shown on the cohesion3d board?

That info is at the very bottom of this page: https://cohesion3d.com/knowledgebase/k40-with-m2nano-cohesion3d-laserboard-installation/

(I had to look it up - I don’t actually know)

What speed are you trying to cut? And what is the ‘default seek rate’ set to in the config file at the top? That controls the movement speed between cuts.

just using a square for a test with a speed of 100 and power of 20. The config file on the SD card?


another clip of the issue I’m having in detail and showing how I can command it to move where I want to. this only occurs when cutting.

If you’re using the jog or movement controls in LightBurn and those work, they use the speed in the Move window, which defaults to 100mm/sec. When cutting, the movement between cuts is using the ‘default_seek_rate’ setting in the config file on the controller, which is 300 mm/sec (24000 mm/min), if memory serves. If you’ve never tuned the settings, that could be too fast for the config or hardware.

Pretty much everything you’ve shown here so far is related to the configuration of the board in your machine, not the software. Increase the motor current and drop the acceleration by about 20% and that will likely get you sorted.