Laser can't find home position

I’ve read alot of posts but have not found an answer. I have an Ortur Laser Master 2. When I press home position, the laser goes to home (left bottom) but seems to want to go further: the motors keep driving. The following warning in console:
Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.

When stopped, I select laser position about 2cm higher and to the right, to see of the laser goes there, but it goes all the way to the top right and wants to go further there also.

If I go to the tab move, right click on get position I get X: -478.64 y: -478.64. In console I typed S#:

Can someone tell me whats happening here?


I set origin position to G10 L2 P1 X-430 Y-400 and now it homes to bottom left correctly. However when clicking on laser position somewhere in the laser bed to move laser there, I get the following command:

G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)
Op of nabij lijn 2:
Stream voltooid in 0:00
[MSG:Reset to continue]

Is there still a setting somewhere that needs attention?

This one solved as wel: cleared offset using G10 L2 P1 X0 Y0.

Also: when I now place an image in the laser bed, it doens’t matter where I place it (left, top, bottom, etc): when I run a frame over it, the frame always starts bottom left.

OK: solved this one: changed start from current position

Now framing en burning don’t work. Still getting the ALARM: 2 code…

FIXED: simply changed “start from” to absolute coordinates again.

All is working fine now.

ok, so now, during burning, I get:

Reset while in motion. Grbl cannot guarantee position. Lost steps are likely. Re-homing is highly recommended.

It stops everytime burning around halfway the burn.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.