Laser console saying "Waiting for connection"

Hello, I am new to the laser printing world and am having an issue with my laser. I was able to use it for a few months just fine but recently after using my expansion kit it doesn’t seem to be working. I’m not sure what the issue could be. I’ve been searching everywhere for some insight on this. I’ve re-downloaded drivers. I tried to reflash the laser itself but get an error with it. Any assistance in this would be greatly appreciated.

Thank you

When you plug your machine does computer make the typical USB sound?

In lightburn, laser pannel, in the drop down what COM port are you selecting?

Yes it makes the connection noise. Currently using COM3. It shows the laser is ready but in the console shows “waiting for connection”. I’ve gone into device manager and tried changing the COM port to 5 & 6. That didn’t seem to help either.

So you confirm in device manager as you plug and unplug the machine COM3 is the right port

Are you adding your profile by hand? or doing a “find my laser”?

Yes and yes. When i try to click “find my laser” nothing shows up so I had to do it by hand.

Lets call the certified Sculpfun resident wizard !

Sounds wonderful, thank you for the replies.

As a final thought, I am assuming your machine homes correctly
You installed the drivers for it

Have you tried LaserGrbl as a sanity check to make sure if you CAN’T get connection on either?

Actually, currently I can’t even get it to home. I downloaded the LaserGRBL and because it looked different, I didn’t know if I would mess anything up, so I just uninstalled it before trying anything.

LaserGrbl and Lightburn are “senders”, so as long as you dont try to run BOTH at once its fine.

Wondering if the machine is actually booting firmware then and or if your COm3 is just the debug port
@misken is the real expert on your machine

Oh alright, I am not sure either. I even bought another cord thinking maybe that was the issue. I also tried plugging it into another port and that doesn’t seem to help either. I’ve just been at a total loss. Doing constant research trying different things. I believe the issue has been going on for about 3 days now. (If I remember correctly)

If anyone can help you is Melvin.
I am not sure on Sculfun machines

Did you reach to their support? if not i would… maybe theyc an guide you fast too

Not a problem I appreciate the reply. I have reached out via email but currently waiting on a reply so I figured I could at least attempt here.

Definitely! Or their Facebook groups are also a good source.

Currently awaiting acceptance there also.

1 Like

Hi there, I’m back from Easter holidays :slight_smile:

So, I understand that you can’t connect neither with LB nor with LaserGRBL? The laser is recognized and gets a COM port assigned? It’s no problem that the laser is not detected automatically, you can also add it manually.


I’m sorry I had gotten to work shortly before your reply. LB says “ready” when it comes to the laser but in the console it is “Waiting for connection” as for LaserGRBL I downloaded it but didn’t want to mess anything up so I deleted it before I did anything there. I have assigned the correct COM and even changed it via physically to another port, and also in device settings to change it to another COM incase for whatever reason one of them wasn’t working. Yeah I’ve read that its isn’t a big deal that it wasn’t automatically detected that’s why I didn’t think it to be a big deal to do is manually.

LB saying “ready” doesn’t mean anything :slight_smile: If the console says waiting for connection, the laser is NOT connected. This message is usually received when either the wrong COM port is selected or it is inaccessible.

Both LaserGRBL and LB are not interfering (except running both simultaneously) so you can install both at the same time, that doesn’t cause any issues.

Which COM port does it get assigned? Check Windows device manager.

It is assigned to COM 3. I’ve confirmed in device manager and that did not work. I also finally got a reply from Sculpfun and they had me download the LaserGRBL and send a video of that not working either.

Can you show a screenshot of the device manager and then the LB window including laser window and console?