Laser disconnects every time I pull USB out of my Mac

Hi, I’m using a MacBook, version 11.2.3 Big Sur, I have a MIRA5 40w laser and I connect my MacBook to my laser via USB. I have no issues connecting to the laser for the first use, but if I unplug the USB from the laser to rework on my files in lightburn, I cannot reconnect using my USB even when I hover over the devices area and right click, it doesn’t reset and just shows as disconnected. I have to restart my Mac each time. It is driving me crazy. In another group I was told to install a driver but during installation of lightburn onto my Mac I was never prompted with this option. Really hope some one can help!

I’m on Mac too - it doesn’t necessarily show in the panel that it’s connected, but it is, as the check for connection is done at start up.

Have you tried a frame?

And is there a reason you aren’t using the ethernet interface?

Big Sur and other MacOS versions include a driver from Apple that has known conflicts with the FTDI driver used by Ruida. The telltale is that you get exactly one use, then the port locks out, and you have to reboot to use it again.

There’s a newer driver at the bottom of this thread:

That one has reportedly fixed it for a few people, but if it doesn’t work for you, there are a few other options above that post in the same thread you can try. They involve varying amounts of fussing on the command line, so we generally suggest an Ethernet cable instead, but try the driver first and let us know if that helps you.

This is my first laser, so I just used the cable that it came with, I don’t have an ethernet cable, annoyingly the machine has built in wifi, but I haven’t been able to connect via that either. Really having no luck

Hi, thanks. So it’s actually got worse as I updated lightburn and now it won’t connect at all let alone more than once, installed the FTDI driver but it doesn’t seem to do anything. Really not sure what to try next

Try this version. Big Sur has been a gigantic pain in the butt, and hasn’t been playing nice. I believe I have this corrected now:
https://drive.google.com/file/d/1FfegjDY1563SKL8QrnxtcngwG4Vra_7-/view?usp=sharing

So I’ve installed an older version of lightburn just to get it working but I’ll have a look at this tomorrow, I’m not holding my breath as from speaking to other aeon users Mac seems to be so problematic. Just so frustrating

For us too, believe me. I’d like nothing more than for Apple and FTDI to get their $h1t together and fix this, but this is what we have to deal with for now. The 0.9.24 builds have worked well for all Mac users who’ve reported back to us.

Theres a very good reason I’m still on Mojave.

None of my apps will work on any version after Mojave, and I love my old pre-CC Adobe. Not going to go on subscription after paying a couple of grand for CS6 apps.

I run all sorts of network weirdness that would be broken by going to a newer OS and nothing in those versions gives me anything I need.