Laser does not start job with a fill layer enabled in version 1.0

Okay I am new so let’s hope this is not user error. I am using Lightburn 1.0 on a mac M1. My Machine is using a Ruida KT332N over USB.

I have created two layers. One with Text on it set to fill. The other with a shape set to line. Both have appropriate settings to cut and fill.

Now if I have output toggled on for both layers and hit start I can see the machines controller will toggle to run and the timer starts counting up but the laser just sits there and does nothing.

If I toggle the fill layer off and run the same thing the laser will run just fine and cut things out. Toggle it back on and the same behavior as before. Just sits there and does nothing.

Now this is the weird part… I have opened the speed/power test and it ran just fine. It seems to just be an issue when I draw something myself and try to run.

I have gone in and downgraded to 0.9.25 and am not experiencing the same issue.

I noticed something similar with version 1.0.
It seems to start fine if the interval setting is 0.090 or 0.095 but other values including 0.100 don’t start.
The software claims the file send successful and the machine run time starts incrementing, but the laser never starts.
I’m using the Ruida 644XG USB device.

If you’re using a Mac / Ruida / USB combination, please try this:

Sorry about posting a duplicate issue. I will read closer next time to see if I can find similar issues. It got up into the mid to upper 90s today and it’s hot in the garage. If I can get out tonight I will give it a go.

Okay I downloaded and tried to use it but for some reason the direction keys seem to be disabled. The home button does work.


The jog buttons not working was a great tip - I was able to reproduce this here, and found the cause. I’ve updated the pending patch release posted here:

Can you try that one and let me know if it also works for you?

I will try tonight!

Sorry I was not feeling well last night so I did not get a chance to try it out. I have good news and bad news :-(. The good news is that with the version linked I was able to use the direction keys to jog the laser. Sadly when I tried to run my program again I hit start and the machine said run and the timer started but the laser just sat still.

Is there any sort of debug information I can provide for you related to this?

And another issue I ran into unfortunately I have not reproduced it past the first try. I ran Clicked the “Get Position” and the application crashed. I am sure it had something to do with the way I started the application and turned on the laser perhaps things were not communicating. Sadly I forgot to grab the stack trace from the window before I closed it.

I’m having the same issue, M1, BigSur 13.3.1, Ruida over USB. I can’t send text, which is only around 124mm x 4mm in size, but can send smaller circles…

I’ve downgraded to 0.9.23 and having the same issue. I’ve used and old prefs.ini file and deleted the current, still not working.

Any suggestions @LightBurn


My best suggestion for Mac users with Ruida devices has been, and continues to be, get a network adapter if you need one ($30) and connect the Mac to the Ruida with a network cable. There are no driver issues, it’s rock solid, and it’s twice as fast.

It seems like each new update of MacOS breaks FTDI compatibility in some new way for some people, and fixes it for some others, and it’s a constant game of whack-a-mole at this point. Every time I’m able to find and fix an issue on my own hardware, it breaks for someone else - versions that I’ve repeatedly had issues with on my hardware work for other people, and I can’t figure out what’s causing it - it’s maddening.

1 Like

I can understand how difficult keeping up with someone else’s code changing! I will have to take a look at the ethernet option. I was under the under the impression that usb was the way to go :slight_smile:

I will look more into it this evening but… Are the controllers doing tcp/ip? Can I throw a wireless bridge on there and set that up? Or is it best to do a direct connection from the computer to the machine and is using some other protocol? I think I brought my network adapter and stuck it a box a year ago :-D. I will dig it out…

This response just posted is worth review.

1 Like

Thanks @lighburn

I’ve gone out and purchased a network adapter, so plugged that into the usb port on laser (no ethernet port) > plugged into ethernet cable > plugged into USB hub > plugged into laptop. Laser doesn’t work. I’ve tried finding it again in Devices, not recognised. Tried to create manually, using the ethernet option (don’t have ISP address) and tried again with the USB option and it doesn’t work.

Could you please just give me instructions on how to roll it back and clear the settings? I’ve rolled it back and I’m having the same issues. Can you please just tell me how to clear the settings so that it can work on 9.something?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.