Version 1.0 - MacOS issues with Ruida

There are no updated settings - I think it’s likely that a MacOS update is the culprit here, not LightBurn. If you were using 0.9.23 successfully, and reverting back to that isn’t working, then something else is going on.

MacOS ships with a driver that conflicts with the one used by Ruida, and they occasionally “argue” over who gets to talk to the port, locking it up. If that happens, power cycling the machine is the only way to get the port unlocked, so try that first.

Converting text to a path is necessary to node edit the text, and quite literally nothing else requires you do it. I’ve seen dozens of FB posts where people suggest converting text to path for everything short of curing back pain, but you never need to do it unless you want to edit the nodes or the individual shapes of the text.

There’s a different driver posted here that some have found fixed their issues:

I’ve tried the above driver, but it’s not working either.

Similar issues here and really hope you can help please.

I am running latest version of Lightburn 1.01 and Mac Big Sur 11.5 Running on Mini mac. I have a USB cable to the machine.

I am getting mixed messages the whole time.If I close lightburn and then switch on, I can maybe manage the ‘frame’ function and all looks good for the machine settings. Then I try to use ‘start’ function for a ‘fill’ or ‘line’ and that doesnt work. Error messages of 'sending problem to laser. Machine may be busy or paused."
then I check machine settings and all settings have disappered. I have attached screen shots for you. thanks for any assistance.

Screen Shot 2021-08-21 at 16.27.38
Screen Shot 2021-08-21 at 16.27.29

I will try a few things that you have suggested here. We did actually downgrade the MAC from big Sur to catalina and that hasnt helped at all. but will investigate some other points that you have suggested. thanks

Hi Lightburn, we have found a way that may help you find a complete fix.
we downgraded the Mac Os to Catalina on our machine, completely rebuilding it. with light burn 1.0.01, the problem of communication remained and it was impossible to engrave fill (funny enough the line cuts was working but not the fill. the files didn’t get overwritten either).
we then downgraded Lightburn to 0.9.24 and bingo. All as it was before. no issue of communication, fill works. perfect.
So it seems that what you did to overcome Big Sur problems have created problems.
Hope this helps

I think I finally understand what’s happening on MacOS / Ruida / USB.

Apple has a bug in the driver that talks to the FTDI chip - it’s ignoring what’s called ‘hardware flow control’. Similar to a conversation between people, it’s possible for one computer to send data to another too quickly. If the receiver starts to backlog, it can turn on a signal that says, “hold on” to the sender, then when it gets caught up, it turns off that signal and the sender resumes.

After a lot of digging, I found a couple posts online that show evidence that Big Sur is not paying attention to that signal on FTDI devices, which means if it sends too fast and the Ruida asks it to slow down, it ignores it and the Ruida drops some of the data, messing up the transfer.

I’ve added code to the MacOS version that self-throttles the transfers to keep them under the maximum rate for the Ruida and this works on all the hardware I have here to test with.

This is a Mac build with a fix in place that’s working on all the hardware I’ve tried it on:

Can anyone on this thread please try it and report back if it’s working or not, and with what hardware and MacOS version?

I will try tonight or in the morning. I am on a BigSur M1 Air if that is an interesting data point.

Thanks @lightburn - it’s worked for me, so far. Just started, so will get back to you if anything crops up. Huge thanks!! :+1:

1 Like

I will try it as well!

1 Like

It worked! thank you for figuring it out for us and not giving up. I’m also on an M1 MacBook Air running Big Sur.

1 Like

Okay just tried it again this morning. Using BigSur on a 2020 M1 Mac Air and it seems to work fine on 1.0.2

1 Like

I tried it but it only worked for one file. After messing around with it trying to get it do another file, I went back to 9.24 (Running macOS Catalina version 10.15.7, I know I haven’t updated to Big Sur I’m always concerned my programs will not work with updates so I wait till others have. But I see the people that commented before me are running Big Sur so maybe it’s time :wink: )

1 Like

Mac Big Sir 11.5.2, 8-Core Intel Core i9, 64 GB Ram.

I just ran the offending file that crashed with version 1.0.0 and 1.0.1. It worked! Thanks for the update!!!

We’re still getting a few issues reported even with this change, so I’ll likely try tweaking the throttle speed to see if we can get it to be more reliable.

Longer term, we have another option we’re testing that will involve a Raspberry Pi and a file (disk image) from us to act as a relay. This is rock solid so far, 2 to 3 times faster than USB, and would let you connect using WIFI over your home network. We may also be able to extend this to include camera support over the same connection.

Mac Big Sir 11.5.2, 8-Core Intel Core i9, 64 GB Ram.

Bad news. After three complete jobs, ranging from 90 seconds to 12 minutes per burn, the software errored out gain.

A small 13 second burn would not send to the laser. I could “Frame” it to check the size, and that would work fine. But I couldn’t get it to burn, then it wouldn’t talk to the laser any more.

I’ve uploaded the file for your review. It did burn successfully with version LightBurn 0.9.24, built Wed 2021-04-21 @ 19:47.

Hatcher Wesley.lbrn (20.1 KB)

Hi, I am experiencing the same issues as mentioned in this topic.
I downgraded to the previous version which is fine for me.
I am on macOS Catalina

hello all

i have downgrade to 0,9 , fix 1,0 and 1,0,1 not work for me I’m on m1 mbp bigsur on ruida6445


I’ve using macOS Big Sur V11.5.2 / Ruida / USB and updated to V1.0.02 but it’s still not working for me

Thank you

Update: I went back to the previous version and now that one won’t work either. I’m at a compete lost. It worked last Friday and now nothing. I have a big job due tomorrow (8/24) so I’m a lot desperate for help over here.

I was able to get the previous version to work :sweat_smile:

I removed your support data to keep the thread a little more compact - we don’t actually need it for this, at least not right now. (and it’s still available in the edit history of the message, which we can see, if we do need it later)