Version 1.0 - MacOS issues with Ruida

I am having an issue - it was an update and now when I send to the laser nothing appears in the send list.

I’m having the same problem. I used the previous version no problem. I have a MacBook. Similar problem to what happened a few months back with a version upgrade.

1 Like

Are you connected with USB? MacOS does not play nice with Ruida controllers over USB, and never has, honestly.

I have a cord plugged in from the pc port on my laser to usb on my Mac.

When you say, “I used the previous version” do you know which version number that was? My MacBook Pro, running Mojave, has no issues right now sending via USB to a Ruida controller, but MacOS has always been a bit spotty with USB / Ruida.

Check the port list to make sure you have a port showing up (Click here in blue - it’ll say (Auto) on your machine):
image

Power cycle the machine and try again - if the port is locked, this may help.

I replaced it once I downloaded the upgrade so I’m not sure there’s a way to figure out which one that was? But Im almost positive it was the most recent version prior to 1.0.

Honestly I don’t know but it was downloaded in June so likely the last version before this one

I am connected via USB - always have been. I cannot get lightburn to connect via wifi

I have auto showing up and I have rebooted the machine multiple times

You mean you ONLY have ‘Auto’ showing up there, and nothing else? (and reboot means shutdown, not just sleep/wake - just making sure that’s clear)

my macbook pro is running catalina - I can upgrade to big Sur if you think this will help

I have completely turned off the laser - waited 5 minutes and turned it back on - a REBOOT.

I have this showing up

For devices, mine is set to auto. There are 3 other options under auto - cu.Bluetooth-incoming-port, cu.cricutair2, and cu.usbserial-agojfm7m7p.

I have it on auto which is what I’ve always used and it’s set to the correct (and only) laser. I’ve completely shut down and restarted my mac and the laser.

1 Like

You always will. What shows up when you CLICK the ‘(Auto)’ drop down. Do you see anything in that list?

also have these options

Try choosing that one.

Try this - disconnect the Ruida, then right-click the ‘Devices’ button, and then click the ports list again. What’s now missing from the list, if anything?

Plug the USB back in, then right-click the ‘Devices’ button again, and open that list, and select whatever was missing and has come back.

(Right-clicking the ‘Devices’ button re-tries the connection and re-builds the list of connected things)

That didn’t do anything different

When I did this, the usb one is missing.

I now have cu.usbserial-AR0K2EIJ as well
however choosing it doesn’t make any difference - still nothing in the file list