Version 1.0 - MacOS issues with Ruida

I believe I’ve got this sorted - I was finally able to get the issue to occur on a dev system with enough repeatability to be useful, and I think I’ve isolated the actual cause and fixed it.

@Judyrie, @JackRider, @Born2BlossomDesigns, @bluebellpaper

Can you try this version and let me know if it also works for you?

1 Like

Thank you for the link. I tested it and it seems everything is now working fine with this version. I really appreciate it.

Everything looks good except for the frames… Sometime the machine do the frame correctly, and sometimes the frame path stop in the middle. MAC (Catalina) with Ruida.

Is this version different then the last posted one above?

Me too… I have been using Lightburn on Mac for right at 2 years no connection issues until V1.0

Hopefully a little info I have gathered may help to solve it.

First I can talk to the laser one time (start) and it acts like it worked, no errors but the laser does nothing. If I then start job again it says laser not connected or busy. If I reset the laser I can again talk to it one time. Also I can “get position” anytime and it appears to be working.

So, Lightburn is connected to the laser but there is a communication issue. Also when I hit “update overlay” it does nothing (this is after sending the first “start”.

But like I said the “get position” does work. So I went back to the previous version and everything works as it should. There is definitely an issue with the V1.0 and communication. I am also on the facebook Lightburn forum and I have seen a lot of others having issues though I think most of them were Windows users.

Ruida Controller. Mac (latest OS).

There is no official Facebook LightBurn group, so those users should come here, or email us.

There is a version posted in this thread above that you can try:

There was a definite issue found and corrected there, and we should be releasing a patch shortly, I just want to have a few users verify that this is working for them.

@LightBurn sorry posted on the other thread. I did download and try this last night. Whati team into was that I could not move the laser position left/right/up/down manually using the move screen. It still responded to the home and to my saved position. Is there anything I can provide to help debug the issue?

I have tried the v1001 you posted to no avail

I’ve updated the version at the link posted above. Can people please try this new one?

Someone posted a symptom, saying the jog buttons in the Move window didn’t work for them, and that was the key to finding this recent error. (This is why we ask that you provide as much info as you can - the weirdest little details sometimes help home in on the problem)

Sorry, I posted on a different thread also @lightburn

I’m having the same issue and don’t have an ethernet port to use.

Cut has worked so far, also has small circle fills, but I cant send text fills. I’ve downgraded to 0.9.23, but that hasn’t worked. I’ve updated the prefs.ini file to one of the previously working backups, but nothing.

I’ve powered off laptop and laser, which hasn’t helped.

I’ve checked that the USB is selected from the dropdown and even tried finding the laser again in devices, but nope.

It frames the job and the jog buttons are working. I’ve tried converting the text to path, but that wont send either.

What I have found strange is I managed to get a couple of words to send in one font, but wont send if I change the font. Some words wont send in any font i’ve tried. Sometimes it will send, but when I mirror, it wont send. If I mirror it back, it wont send. I type in the same word again, it wont go… It seems to be really random, but no matter what I try, I can’t get the one word I need to engrave, in the font and mirrored. That’s all I’m trying to do is get one word. “Patrol” in the font Deloire. It was sending the letters individually, so I thought great, I’ll just lay all of them out individually, where I want them to be (and mirrored), but they wouldn’t send!

I’ve also seen the sending file box pop up, occasionally, which I’ve never seen before.

As I’m trying different things, to see if it will send, I’ve been stopping the job before it starts - just when the head moves. Though one time I let it start, LB hung, with the wheel turning and I couldn’t stop the engrave, and had to force quit once it finished, as LB was still hanging.

Sorry for all the detail, but you did say the more detail the better. Just hoping some of this helps.

As the downgrade hasn’t worked and the updated V1.0.1 isn’t working, I’m really stuffed up in a big way, so any advice would be greatly appreciated!

Whilst you work on a fix for the new version, how can I clear out the updated settings from 0.9.23 so that I can at least get that working, urgently?

Macbook Air M1
BigSur 11.3.1
Downgraded LB to 0.9.23
USB to Ruida
Bodor Laser

Apple sells an Ethernet adaptor for $30. I highly recommend going this route, as it seems like every update to MacOS messes up a few users connecting to Ruida over USB.

There are no updated settings - I think it’s likely that a MacOS update is the culprit here, not LightBurn. If you were using 0.9.23 successfully, and reverting back to that isn’t working, then something else is going on.

MacOS ships with a driver that conflicts with the one used by Ruida, and they occasionally “argue” over who gets to talk to the port, locking it up. If that happens, power cycling the machine is the only way to get the port unlocked, so try that first.

Converting text to a path is necessary to node edit the text, and quite literally nothing else requires you do it. I’ve seen dozens of FB posts where people suggest converting text to path for everything short of curing back pain, but you never need to do it unless you want to edit the nodes or the individual shapes of the text.

There’s a different driver posted here that some have found fixed their issues:

I’ve tried the above driver, but it’s not working either.

Similar issues here and really hope you can help please.

I am running latest version of Lightburn 1.01 and Mac Big Sur 11.5 Running on Mini mac. I have a USB cable to the machine.

I am getting mixed messages the whole time.If I close lightburn and then switch on, I can maybe manage the ‘frame’ function and all looks good for the machine settings. Then I try to use ‘start’ function for a ‘fill’ or ‘line’ and that doesnt work. Error messages of 'sending problem to laser. Machine may be busy or paused."
then I check machine settings and all settings have disappered. I have attached screen shots for you. thanks for any assistance.

Screen Shot 2021-08-21 at 16.27.38
Screen Shot 2021-08-21 at 16.27.29

I will try a few things that you have suggested here. We did actually downgrade the MAC from big Sur to catalina and that hasnt helped at all. but will investigate some other points that you have suggested. thanks

Hi Lightburn, we have found a way that may help you find a complete fix.
we downgraded the Mac Os to Catalina on our machine, completely rebuilding it. with light burn 1.0.01, the problem of communication remained and it was impossible to engrave fill (funny enough the line cuts was working but not the fill. the files didn’t get overwritten either).
we then downgraded Lightburn to 0.9.24 and bingo. All as it was before. no issue of communication, fill works. perfect.
So it seems that what you did to overcome Big Sur problems have created problems.
Hope this helps

I think I finally understand what’s happening on MacOS / Ruida / USB.

Apple has a bug in the driver that talks to the FTDI chip - it’s ignoring what’s called ‘hardware flow control’. Similar to a conversation between people, it’s possible for one computer to send data to another too quickly. If the receiver starts to backlog, it can turn on a signal that says, “hold on” to the sender, then when it gets caught up, it turns off that signal and the sender resumes.

After a lot of digging, I found a couple posts online that show evidence that Big Sur is not paying attention to that signal on FTDI devices, which means if it sends too fast and the Ruida asks it to slow down, it ignores it and the Ruida drops some of the data, messing up the transfer.

I’ve added code to the MacOS version that self-throttles the transfers to keep them under the maximum rate for the Ruida and this works on all the hardware I have here to test with.

This is a Mac build with a fix in place that’s working on all the hardware I’ve tried it on:

Can anyone on this thread please try it and report back if it’s working or not, and with what hardware and MacOS version?

I will try tonight or in the morning. I am on a BigSur M1 Air if that is an interesting data point.

Thanks @lightburn - it’s worked for me, so far. Just started, so will get back to you if anything crops up. Huge thanks!! :+1:

1 Like

I will try it as well!

1 Like