Laser Fährt bei der Gravur nicht durch sondern bremst immer wieder (Laser does not drive through during engraving but brakes again and again)

Ich habe eine frage zur software.

Mein Problem liegt darin das beim Gravieren eines Bildes, der Laser an jedem punkt lagsamer wird und dann wieder beschleunigt.
Ich hätte aber lieber das der Laser einmal durch läuft und den Laser nur an den stellen ein und aus schaltet.

Ist es möglich das es daran liegt das ich den sterbefehl
M03/M05 Benutze?
Ist das normal so oder habe ich eine Einstellung falsch getroffen.

vielen dank schon mal, hoffe das Problem wird gelöst.

I have a question about the software.

My problem is that when engraving an image, the laser slows down at every point and then speeds up again.
But I would prefer that the laser runs through once and only switches the laser on and off at the points.

Is this normal or have I made a wrong setting?

Thank you very much, hope the problem will be solved.

Open the console in LightBurn and enter $$.

Copy and paste what you see there into a reply here. There is a Laser mode that should be enabled - unless it is not available to you.

Did you Flash the controller with Knutwurst? There may be build-options that you can select as a next step if Laser Mode isn’t available.

Also wenn ich $$ in die konsole eingebe kommt nur echo:Unknown command: “$$”

I was hoping Marlin used the same ‘machine settings’ query tool.

There is a laser mode that doesn’t pause or stop the way a milling machine spindle needs to pause. Looking at Marlin quickly it seems that it’s a ‘Build-time’ configuration change but i know nothing about Marlin. I’ll move this to the Marlin group and i’ll dig in a little bit to see what i can find out.

Engraving an image would normally have consistent speed across the entire line with only the laser head turning on and off as necessary.

I recall something about Marlin potentially behaving this way.

Try using Inline mode if you are able. It allows for variable power and is similar to GRLB laser mode. I recall someone saying this resulted in smoother motion on Marlin controllers.

Die inline steuerbefehle funktionieren leider nicht, der druckkopf bewegt sich zwar aber der Laser feuert nicht bei der Art und Weise der Ansteuerung.

Unfortunately, the inline control commands do not work, the print head moves but the laser does not fire in the way it is controlled.

Is this the firmware your controller is using?

yes that’s right, that’s the software i use

Inline only works in relatively newer versions of Marlin. I believe 2.0.4+ but could be wrong. I don’t know if it’s compiled by default or if it needs to be configured but might be worthwhile to see if there’s an update available that you can install.

Ich habe mir jetzt schon die neue Software runtergeladen doch es funktioniert immernoch nicht richtig.

I’ve already downloaded the new software but it still doesn’t work properly.

Are you talking about new version of LightBurn or new version of Marlin?

Are you connected to the laser and running the job from LightBurn or you are saving g-code and running it another way?

Ich habe die neueste Version von Knutwurst drauf gespielt (Marlin basierend)
Habe aber auch die neueste Variante von lightburn auf dem Laptop.
Ich steuere den Laser direkt über lightburn an.

I played the latest version of Knutwurst on it (Marlin based)
But I also have the latest version of lightburn on the laptop.
I control the laser directly via lightburn.

FIRMWARE_NAME:Marlin 2.0.x (knutwurst, Github) (Feb 18 2022 13:55:15) PROTOCOL_VERSION:1.0 MACHINE_TYPE:Knutwurst’s Anycubic Printer EXTRUDER_COUNT:1 UUID:b6153152-86fb-4cd8-bda7-91c6a04c467d
































Kannst du mit diesen daten was anfangen?

I see this in the release notes for 1.4.3.

Going to the link shows this:


S is interpeted as the configured value range: PWM (default), Percentage, or RPM. (See CUTTER_POWER_UNIT)

M3 and M4 aren’t needed with LASER_POWER_INLINE and LASER_MOVE_POWER enabled. Power is set directly in G1G5

It’s not clear if or how LASER_POWER_INLINE and LASER_MOVE_POWER are to be enabled (I assume at compile time) but seems you can still use it if by setting I with the M3 command.

I just checked the g-code output of LightBurn using Marlin with Inline and it’s not clear to me that it’s valid syntax based on the documentation. However, it’s well known that the documentation for Marlin isn’t always current. LightBurn g-code shows I inline with G commands.

You may want to try modifying the g-code to include an M3 with I and see if that behaves differently.

I have now tried to rewrite the g-code
G1 X-0.141 M03 S2.5
G1 X-0.282 M03 S0
G1 X-0.625 M03 S0
G1 X1.411Y0.141 M03 S0

when I write it like this, the laser does not fire

G1 X-0.141
M03 S2.5
G1 X-0.282
M03 S0
G1 X-0.141
M03 S2.5
G1 X-0.847
M03 S0
G1 X-0.141
M03 S2.5
G1 X-0.423
M03 S0
G1 X-0.142
M03 S2.5
G1 X-0.282
M03 S0
G1 X-0.141
M03 S2.5
G1 X-0.282
M03 S0
G1 X-0.141
M03 S2.5
G1 X-0.282
M03 S0
G1 X-0.142
M03 S2.5
G1 X-0.282
M03 S0
G1 X-0.141
M03 S2.5
G1 X-0.847
M03 S0
G1 X-0.141
M03 S2.5

and so he always makes a short stop

I’ve been working on the problem for a long time now. Unfortunately, I am not familiar with the rewriting of the firmwase. :frowning:

Can you try:

M3 S2.5 I
G1 X-0.141
G1 X-0.282 S0
G1 X-0.625 S0
G1 X1.411Y0.141 S0

When I enter the g code, laser just moves a little and turns on the Laser.
But after that, lightburn and my laser stopped responding.

Actually, I don’t know where you came up with the code so I just matched it. It’s not going to move a lot.

Maybe try this:

M3 S2.5 I F500
G1 X10
G1 Y-10
G1 X-10
G1 Y10

That should draw a square 10x10 mm.

that works

Try the same code but without the ‘I’ in it. Does the motion change? If so, I think that means inline is working. There may just be a syntax issue with the code generation.