Laser goes out of whack


I’ve been getting these random cutting errors lately and I’m wondering if something is wrong with my light burn software or the ruida 6445 controller. Whenever I do an engrave followed by a cut, the machine loses its way and starts cutting erratically. Before the job I frame and everything is fine. I’m using a MacBook and a black/gray 80w Chinese laser, Any ideas?

I had this issue too and contacted support over it.
They said when images are too big to process before lasering starts it stuffs up.
I deleted all the jobs I had sent to the controller (good to keep this cleaned out too), and for big images or high DPI engraves try holding Shift then Send which will ensure the whole file is sent before starting job.
I use this technique now for big jobs and had no worries in past few months.

Not sure if it’s the same problem, but I have learned not to have a vector cut picking up from the end of a vector engrave line. The 6445G just doesn’t make the switch over quick enough for some reason and the first bit of cut is squiggly and doesn’t penetrate completely. I run the preview at the point where I switch from engrave to cut to make sure they don’t follow each other.

I haven’t been transferring to the controller, I just start it from Lightburn and most of the time I have no problems but when it is a bigger job with engraving and cutting it seems to mess up. So are you saying you send it to the ruida controller first and then start the job from the laser controls? And when do you hold shift in that scenario?

Yes, try sending to controller first. Hold shift down while pressing Send and it will start automatically when job is sent in its entirety. Worked for me but Lightburn Support was super helpful so if it isn’t the same problem and you can’t get a solution I highly recommend flicking them an email.

Ok, thank you. Maybe Oz will chime in and explain what’s happening too.

Can you share the settings for the file you were running? How are you connected to the machine? (USB, net cable, or WIFI?) If you’re using ‘Start’, try using ‘Send’ instead. If you’re running really fast engraves, it’s possible that the controller is too taxed running the job to also receive the incoming data properly. This is relatively common with image engraving at high DPI / speeds.

I am connected via USB, my dpi is set at 254, engrave speed is 400 and I have always used “start” to begin the project because I thought once the file transferred to the controller that all the data was successfully transmitted. The engraving came out good but when it went to the vector portion it messes up and seems to make a random move.

How do I “send” instead of “start”?

Sorry for my ignorance.


You don’t with a GCode based machine - they all stream the code live. DSP controllers buffer the whole job.

Would you say that my settings were taxing the controller too much and from now on I should use send on larger jobs? Also where do I see the file size before sending so I can better predict when an error may occur?

It’s not necessarily the size of the job, it’s the complexity - Sending a vector engraving with lots of long runs is less work for the controller than one with lots of short runs, or a dithered image where it’s runs of a pixel or two. The more complex jobs, ones running really fast, use more compute power.

But what would cause the vector to all of the sudden jump to the wrong location? Was this error transferred from the beginning of the “start” command and I only see it when it reaches that point of the vector or is Lightburn continuously sending the data and then it gets over taxed and loses its reference? Is there any way to know this is going to happen by looking at the controller?

If the controller was doing too much at the time and missed a block of data it could screw up like this. It can also happen on rare occasions with a bad USB cable or connection. If you Send instead of Start, you can see the job on the laser screen before you run it, and the controller is only doing one thing at a time, so it’s less likely to mess up.

USB on Ruida is a 1.1 device - slow, slow, slow. No matter what your computer has, it will not work faster than 19200bps which is the Ruida’s comms setting for USB - the Ruida uses an FTDI FT254R chip which has a total throughput of 1Mbyte/sec.

This image is a vector and 65mm x 80mm (2.5" x 3") and produced an RD file of 21Kbytes.

Screen Shot 2021-01-27 at 4.51.46 PM

Converting it to a 254dpi bitmap, the file size is 127Kbytes.

It’s easy to overload the USB.

Is there any reason not to use Ethernet? The speed is 100MBit/sec, so 10x as fast.

You mean I can just run an Ethernet cable from the laser to my laptop and it will communicate? Or do I need to use a server and configure the IP address? Does the laser have internet connectivity?

You can just connect an ethernet cable between your PC and the laser. But, it’s a lot easier if you have a spare router port.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.