Laser is busy error sending picture

2.5" tall
450 lines per inch
File size 1.6mb
Gets to about 37% and I get an error.
Ethernet connection

Any hints for me?

Works from USB drive for now.

Cabled Ethernet connection, or WiFi? (and are you on TopWisdom still?)

@LightBurn

Cable
Cat6
Ruida RDC6445 controller now.

Non image projects work fine.

This is frustrating…

It’s ruining material

It is starting the engraving before the file completely sends. That could be part of the issue maybe?

That really depends on how much work the controller is doing. If it was an image I’d say that was a strong possibility. I can’t see your settings, but if you’re running fast with a detailed job, yes that’s possible.

Ruida controllers use UDP for network transmission, which does not guarantee packet delivery like TCP does. If a packet is dropped, there is no option to recover and it just quits the transfer. Using ‘Send’ to push the file to the laser is better when networked, because it does not start the job, it just transfers it to the laser. You go to the control panel, press the File button, choose the file, and press Start on the machine, and that will run it. If the transfer fails, no material loss.

Having said that, cabled connection is usually solid, so I’m not sure why yours is failing. Do you get any messages on the controller itself? (like not enough extend space, for example?) If the controller encountered an error while running the job, like you were too close to the side to allow the overshoot required as it gets close to the middle of that file, it would error when it got there, and that could cause this.

No. It just starts and errors in the software.

File was 253 kb.

500mm/s

500mm/sec is probably why - you might be getting ahead of it.

When you say “file was 253kb”, is that the number being sent to the laser, or the size of the file on your hard drive? The file size on your hard drive is mostly irrelevant. If you click ‘Save RD File’, the size of that file is how big the data being sent to the laser is.

File size on a thumb drive (rd file saved).

is there a way around that besides go slower?

Yes, use ‘Send’ instead of ‘Start’, then start it from the controller. That way the machine is only doing one thing at a time - receiving or running, but not both.

1 Like

I had no clue! Awesome. Thanks Oz for always setting me straight down the right path!

That didn’t work.

5.5" photo.

Maybe too much lines per inch? 600

No amount of settings changes will allow me to send.

This looks nothing like the image shown in the original post - have we moved on to something else?

I thought you said the file saved as an RD file was 253 kb? A 5.5" picture, dithered at 600DPI is not going to be 253 kb, and depending on your image settings, it might be too large for the controller memory.

Saying things like, “I’ve tried everything” is not useful, as it doesn’t tell me what, specifically you tried. I need more info, and specifics, like “I have a 5.5” x 3" image, set to 600DPI, Stucki dither. When I click ‘Send’, it goes for a little while then quits, and I get this message."

I’m trying other photos.

The other one was a larger vector engraving.

No larger engravings are sending or running.

I tried 100 lines
I tried 200mm/s

The photo was exported from gimp.

Show a screen shot of the UI with the photo and its dimensions visible, then a screen shot of the Cut Settings window that pops up when you double-click the layer.

If you click ‘Save RD file’ and look at the file size, how big is it?

I tried 200dpi also. I tried 200mm/s.