Laser is grinding going ballistic and not framing correctly

Lightburn up to date 1.3.01 and now the laser when framing is going ballistic grinding and not framing right. I have projects to do on a time line and if Lightburn will not run when I need it maybe I need to find another software.

Why can’t lightburn frame properly without grinding noise. Was there an update? Why all the sudden is this happening with Lightburn… and it’s just not the noise it is not framing properly at all. Have to find something we can count on or find something different.

Did you recently update Lightburn? To my knowledge Lightburn does not push out updates so any updating would have to be a deliberate action.

If you did not update Lightburn, it sounds like you may have some mechanical problems related to you laser. Make sure all the grub screws are tight, the belts are not lose or worn and mechanical limit switches (if so equiped) are working properly.

Can you please describe the framing error? Is the laser traveling to the wrong spot? Are you comfortable sharing the Lightburn file that demonstrates these issues? If so, post it here and other people will certainly take a look at it to see if the problem exists with the file.

1 Like

@JohnJohn
These seem to be duplicate topics. Can they be combined?

thanks

It is not a mechanical issue I have an image when framing will grind when it gets to the third side of project and then it will go off project and stop. I then took the same image made it smaller and still grinding when framing. I then shut down computer and laser restarted and framed smaller image and it frames just fine until I make the image larger again then it will do the same until I shut down and make smaller. I need this to work today.

Can you please describe what this means? Is it the top, bottom, left or right side?

I’m not convinced this isn’t a mechanical issue because you can successfully frame the image at a smaller size. That makes me think you have a worn belt and/or missing teeth. When you make the image smaller, your laser head isn’t traveling to the worn part of the belt and so frames correctly.

But I’m kind of just guessing here too.

Can you confirm if you did or did not update Lightburn, please?

Lightburn is up to date 1.3.01 which was done a few days ago and we have made other projects up until yesterday. One project finished I started another one and it would not frame without the grinding noise. I will start framing Left side, bottom, correct and no noise it will go to right and be fine until it gets to the top start stuttering and noise then then top the laser will go farther right of the project not even on the board that I am working on and stutter and noise. Then the framing will stop somewhere in the middle. We have taken all belts off cleaned and examined no missing teeth or worn spots on any and reassembled and still have the noise and not framing correctly

This is interesting. We’re all hoping to help you diagnose and solve the problem.
LB has a variety of motion options that can send the laser head in many unexpected directions, but the reality is it usually goes exactly where we’re telling LB to send it, unless of course you’ve discovered a LB bug, a firmware bug, or you have mechanical failure. The first assumption should always be that we’re mistaken and telling LB to go somewhere it shouldn’t, in general or for a specific design or job.

Case in point, I can draw a small 100mmx100mm square in the bottom left corner of the workspace and if I use Start From: Absolute Coords it can frame or cut just fine,
but if I Start From: User Origin with user origin at X0Y0, and my Job Origin is bottom right corner of the shape, and I have Cut Selected Graphic on, Use Selection Origin on, then frame or attempt to cut the laser head will crash in or near the bottom right corner.
Same shape and design, different setup. I’m just trying to say its easy to make these mistakes at times.


The gcode in the console is from a Frame operation, the first stream is starting from Absolution Coords, the second is User Origin as described above. The first was fine, the second crashes on the “G0 X-149.993Y-49.993” move from X50Y50.

Give this test case a try in Absolute Coord mode, moving the square around on your workspace and framing it. I don’t recommend that you try the User Origin case that forces a crash, no need to force a crash. But eventually use different mix of Start modes and selection modifiers and you’ll see how those affect outcomes.

Either this will demonstrate you may have had a job setup wrong or you will find a mechanical issue in certain areas of your workspace, or some other discovery that may lead to a solution for you.

Another item to consider is that at certain speeds a stepper motor can make a growling sound, usually very low speeds. You mentioned grinding, do you see evidence of metal or rubber shavings ?

Good luck.

Done.

I’m also going to move this into the Sculpfun section.

Take heart, these robot engravers aren’t terribly creative. They most often behave as instructed. So, that’s where we have to look.

In the Console window in LightBurn, we can request reports from the engraver asking what its assumptions (or settings) are. Then we can compare those settings to what LightBurn is using and see if a discrepancy exists.

With the Sculpfun connected and LightBurn running enter the following report requests one at a time into the Console window in LightBurn pressing Enter after each one.
$i,
$$
$#
?
$

Please Scroll up in the console window to the $i and select all the text from there down. Then Copy and Paste that text into a reply here. You can copy the whole string at once. It’s a lot - but it will tell us nearly everything.

Early firmware would accumulate offsets.
It may just be a matter of clearing an odd setting.

If you can do a smaller frame without issues, it’s definitely no LightBurn problem in my opinion. In most cases, it’s either mechanical or firmware setting related.
Though, LB sometimes has some bugs, of course.

  • First, I’d do a clean installation of LB and add the laser again (manually is best).
  • Then go through this guide: Guide to mechanical adjustments and maintenance and check the mechanics, especially the grub screws, these tend to be loose / get loose occasionally
  • Check if the firmware settings are still correct. If it’s a Sculpfun laser, you can use the table at this page to check: Firmware Update & Settings - Diode Laser Wiki (LB seems to alter some firmware settings randomly sometimes)

Then check again.

I have been unable to get to this all week so today I try again and still grinding and not framing right it is sporadic and all over the place. This is the copied console codes for a simple box with letters inside. What is wrong and why did this stop working all of the sudden.

Waiting for connection…

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

error:9

G-code locked out during alarm or jog state.

[MSG:Caution: Unlocked]

ok

[VER:1.1h.20190825:]

[OPT:V,15,128]

Target buffer size found

ok

<Idle|MPos:0.000,0.000,0.000|FS:0,0|WCO:0.000,0.000,0.000>

ok

<Idle|MPos:0.000,0.000,0.000|FS:0,0|Ov:100,100,100>

ok

Starting stream

Stream completed in 0:09

<Idle|MPos:0.000,0.000,0.000|FS:0,0|Ov:100,100,100>

ok

<Idle|MPos:0.000,0.000,0.000|FS:0,0>

ok

Starting stream

Stream completed in 0:09


I would like to send a video so you can see what it does when framing

It’s better to set the job origin to bottom-left instead of center. If you start the job like in your screenshot right after the start of the laser, this won’t work because the laser would try to move into negative space. Have a look here: Coordinate systems & workpiece alignment - Diode Laser Wiki
Make sure to set the 0,0 position correctly, then use bottom-left as starting position. That should work.

1 Like

still not working framing still making noise and not framing project

Did you check all screws, and belts etc. for lose or worn out conditions?
I think a video would be beneficial. And show all detailed layer settings as well as LightBurn and device settings.

I have a video but I cannot load into the forum where would you like me to send it to

Maybe use a file share website like https://tempclip.com

1 Like

Can anyone correct the problem I am having with lightburn not framing correctly and making a grinding noise. I have projects to do and running out of time

I have uninstalled and reinstalled and the same grinding noise and framing not correct at all. What is wrong with lightburn

@nefootball you’ve not replied specifically with results of having tried any suggestion that’s already been given to you. Pick any, but this is a good place to start.

1 Like