Laser jumping on X-Axis


I hope somebody can help.

My laser (XTool D1 10w) skips on some projects using Lightburn but if I run the exact same project through Laserbox it burns perfectly.

This is the file in question. I saved the picture from the preview and imported it into Laserbox to get it to work.

Garfield Final_backup.lbrn2 (100.1 KB)


There may be more to it as I know there are people with D1 rapid speeds being too high but in this particular case I suspect the biggest issue is that your cut speed is extermely high at 18,000 mm/min. Is this the same speed you’re using in Laserbox?

Try slowing down to see if you’re having the same problem.

If so, can you describe or attach a photo showing the type of skipping you’re seeing?

Thanks for your reply.

I have been using the same speed and power settings on both.

I don’t think it is a speed issue because I have experienced the same skipping at speeds of 2-3mm/s (see the attached pic of the heart).

I have attached two pics of the slate I tried the Garfield job on and you can see it jumped every time. The overlapping clear engraving is the first attempt with Laserbox.

Please let me know if there is anything else you need and thank you very much for your help.

There may be more than one thing going on.

For the garfield one that looks like the belt is skipping. Recheck belt tension. Make sure there is no slack in the belt. They should be taught but not stretched. Especially check X axis belt in this case.

The heart one could also be caused by the same issue. It may also be caused by the known rapid speed issue. Rapid speeds are used to move the laser head between components of the burn. In this case, though, if you’re having an issue with the belts in Garfield this would cause an issue here as well.

First focus on eliminating skipping on the belts. Then potentially address other issues after that.

1 Like

Thanks very much.

I have gone back, tightened the x axis dropped the speed to 1000 and it still skipped every time. I went into Laserbox and ran it at top speed (which I believe is 10,000) and it came out perfectly first time.

I even ran the program through another laptop (not sure if that would even do anything) and got the same results.

I am so confused!

If this is the case then it’s almost certainly the known issue with rapid speeds in D1 firmware being set too high and unable to be changed.

Basically this affects any motion using G0 g-code command.

It could be the stepper simply can’t keep up with the requested rapid speed or the belts are still slipping. Either way, it’s not currently configurable as far as I know. Not sure if xTool is working on a fix.

We were wondering if it might have been the firmware on the laser itself that was the issue and we were thinking about reinstalling it but from what you are saying it seems that would make no difference.

I’ll look more into the issue on the forum and see if I can understand it more because Lightburn is light years ahead of Laserbox and I don’t really want to stop using it. It was the fact that the XTool was now compatible with it that cemented my decision in buying it in the first place.

Thanks again for your help.

I assume you’re on the latest firmware. If so then likely no benefit in reflashing.

Are you able to run gcode in laserbox? If so might be worth trying to save gcode from lightburn and running in laserbox.

This is my first laser… I don’t even know what G-code is yet.

I would guess no because it is so basic.

Goode describes the control language used to drive numerically controlled machines including CNC, lasers, 3d printers, and more. LightBurn generates gcode to communicate with gcode controlled devices.

It is very basic and there is definitely nothing obvious in the software showing the ability to import any gcode.

So the gcode is what appears in the console. How much is there to gain from actually learning some of the language?

This depends on how you plan to use the laser and how closely you’d like to understand the underpinnings. It’s extremely useful for troubleshooting and helps to dispel any mystery on how things are operating and whether or not a potential problem scenario is caused by software or hardware.

If you were ever to do CNC mill work or something related you’d be pretty much obligated to learn at least the basics. There was a time when a lot of milled parts were hand-coded. A lot of that has gone away with CAM software but still very useful in that space.

If you want to use your laser in a similar way to craft vinyl cutter that’s fine too. Lasers tend to be a little more fussy as yet, though, so there is some payoff to understanding more of the mechanics and underpinnings.

Thanks again,

I think I will looks at the basics as I would like to have some understanding of what is running through the console because other that x and y limit triggered it is pretty much foreign to me.

I really appreciate all you help and advice on this.

Note sure if you’re following any other topics in this forum but take a look at this post. I didn’t think this was necessarily your problem when I initially responded but I realized it’s possible and worth considering. It was hard for me to tell from the photos.

It doesn’t look like my problem from the video. For me there is a definite clunk and then the x axis has jumped a few mm but I will give it a try and see if it makes any difference.

Actually looking back at the pics it isn’t even a jump it continues to burn the same words twice in two different positions.

I got the impression it had skipped position and continued at a different spot. Are you saying you got 2 separate full burns? That’s unusual.

I had thought that since you have 2 passes on the text layer that the laser had lost steps during the rapid move that is occurring between the 2 text boxes. That could account for the text being burned twice (the second pass). But wouldn’t account for 2 full repeats of the burn (4 total passes).

The fast whitespace scan could help if the skip was occurring between white parts of the same object. I didn’t think that was the case but I could have missed something in the photo or design. Still likely related to the rapids speed issue but wanted to bring to your attention just in case.

Yes. I’m pretty sure there are 2 separate burns. If it skipped I think I should see half of a letter in onw position and the rest in another rather than 2 copies of the same letter a small distance apart.

It is such a complicated piece of software but I am enjoying solving the problems that keep arising. However I may have to post another question shortly. I will search the forum first

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.