Laser lights up but won't engrave or cut, help please

Hello everyone,

I can’t seem to get my FoxAlien Reizer 20W to work with Lightburn. I’m trying this software out on the trial and I like it visually and usefully a lot more than LaserGRBL, except for the problem that it won’t engrave or cut at all; I know the laser works, when I run things through LaserGRBL it works fine. Anyways when I submit a job to the machine with Lightburn, the laser will turn on, it even follows whatever path it is that it’s supposed to be cutting or engraving, but nothing is actually engraving or cutting at all. So after trying to read other posts where people had problems and trying their resolutions, none of those suggestions seemed to work so I figure I would ask.

Lightburn version is 1.0.06. The firmware on the machine is GRBL 1.1f; when I initially plugged in the machine it kept wanting to use the iLaser controller/profile, so I swapped it to GRBL (and I’ve tried using all 3 profiles without any luck). The command $$ returns the following:

$0=5 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=2 (dir port invert mask:00000010)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=0 (status report mask:00000000)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=1 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=250.000 (homing feed, mm/min)
$25=2000.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=2.000 (homing pull-off, mm)
$30=1000 (spindle max rpm)
$31=0 (spindle min rpm)
$32=1 (laser mode, bool)
$100=160.000 (x, step/mm)
$101=160.000 (y, step/mm)
$102=160.000 (z, step/mm)
$110=20000.000 (x max rate, mm/min)
$111=20000.000 (y max rate, mm/min)
$112=20000.000 (z max rate, mm/min)
$120=300.000 (x accel, mm/sec^2)
$121=300.000 (y accel, mm/sec^2)
$122=300.000 (z accel, mm/sec^2)
$130=800.000 (x max travel, mm)
$131=400.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

From what I’ve gathered, $30 should be 1000 since that’s the power, and $32 should be 1 to have the laser on and in dynamic mode.

Under Device Settings, S-value max is set to 1000 as it should apparently be since it’s a newer firmware, so it shouldn’t be 255:


And on the cuts/layers menu, power is set to 100%:

So yeah, I’m pretty much at a loss. Laser turns on, but won’t engrave or cut. I’m also having issues with alarm messages related to limits, which is also weird considering I have it set at the correct 400mm/40cm this machine’s supposed area is, so dunno why I’m getting that (I was trying to engrave a grid onto my plywood platform I have the machine on to mimic lightburn).

Any and all help would be much appreciated. I like this software and would love to buy it, but if I can’t get it to work that would be a bummer, in addition to having to go back to LaserGRBL.

Thank you.

Your units are set to mm/s. I’m guessing your speed settings in LaserGRBL are assuming mm/min. So you’re liking going much faster than what’s working in LaserGRBL. You can change units in Edit->Settings.

…and now I feel like a bit of an idiot, sometimes it’s the simplest things you miss lmao. It pretty much worked perfectly when I swapped from mm/s to mm/m. Thinking about it, the last time I really ever messed with a laser engraver was a CO2 model, so that’s why I expected to see things in mm/s, but sure enough with these diode ones, it’s mm/m. But yes, that worked perfectly.

Now if only I can figure out all these wonky alarm lock issues, is the work area truly not 400mmX400mm as well? It’s what this machine’s work area is listed as, but for example when I tried to burn in a matching grid for the wood base I have the machine on (to make it easier to align things), it keeps saying items may be out of bounds with a 400mm length line.

Does your machine have limit switches and go through a homing process? If not, this could just be a matter of sorting out coordinates in this situation.

Common Grbl Setups - LightBurn Software Documentation

Most diode lasers tend to be pretty good about the work space size although some can be a little aggressive. But in general I would say you can rely on the stated size.

I am having the same problem with a Universal Engraver 15W

Command $$ shows the following


I am completely new to this. The laser works with the provided software but not with Lightburn.

Please Help

Please start a new thread. It will help you fully state the problem and prevent assumptions based on previous content here.

This will help too.

i added to this thread because it is the same exact problem but with a different machine which i clearly stated in the question

As @JohnJohn pointed out, it is best to start a new thread, so your questions get the attention deserved.

I see your new post. Thank you for doing so. :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.