Laser lines across work when doing line work

What’s up guy? I have jtech 14w dual laser on my shapeoko xxl. When doing fill on a project everything is good but when doing like work it’s leaving a line while moving to next spot. I have seen some post about setting $32=1. Mine is set to that. What else could be causing that?

Did you look at this in the ‘preview’?

It’s odd because it’s not everywhere it moves, such as from letter to letter.

Can you drop the .lbrn2 file onto the reply window so we can examine it?


Here is the preview

Can you drop the .lbrn2 file here for us to examine.

I can see the path (red) on the preview where it’s supposed to move between ‘characters’ it is also ‘burnt’ there and should not be.

What is the difference between the text layer and the number layer?


49 LOGO.lbrn2 (55.0 KB)

Looks a bit different, but it looks like it should work OK.

I don’t know what to advise you to do, hang in there and lets see if someone can answer it or suggest a path to figure out what it is.

It looks like it’s not shutting off when it transverses across the letters but doesn’t do it with the number…


Yeah numbers are good but don’t understand why on lines it’s doing that. Fill has no problem on anything that I have done.

Some early grbl variants don’t use the spindle PWM pin to control the laser. They use a coolant pin from a CNC controller. This can also generate the novel traverse lines.

When you first connect to your engraver with LightBurn, what message do you get in the Console window? Please copy & paste it from the Console window into a reply here. Knowing the grbl variant you have in the engraver controller is key to troubleshooting.

The next test would be to enable the Fire button in the Move window from the Device Settings pop-up. It’s under Edit, then down toward the bottom you’ll see Device Settings.

Once that switch is green / active open the Move window and set the power to 2% then (with your safety glasses on) tap the Fire button to turn it on for a second or two - then tap it again to turn it off…

The expected behaviour is that the laser will light at 2% power before sending your job (enough for positioning and framing with protective glasses) and it shouldn’t mark your work and it shouldn’t engage a coolant function.

If the fire button doesn’t light the laser as expected, it may be triggering from a coolant pin - the coolant pin would come on while the job was running but may not start at the origin. If the laser marks the work at 2% power, we can dig into the PWM calibration a little further.

I did watch it on a line project and laser doesn’t turn off when going to next letter

Is this the machine/controller you have?

Did you follow these instructions?


Yes i followed video from their website for the Shapeoko xxl pro.

When I get a chance I’ll see what they recommend… busy today maybe John can check it out… This is the best data I’ve see on it, but didn’t spend the time to watch/read the article.


This is really interesting.

Step 9 sets the laser parameters.

I’m pouring over the instructions trying to understand how the PWM behaviour works.

More tomorrow.

Any luck with my issue?

I feel that we may be seeing a symptom of a configuration setting or a pwm pin allocation error. If you’re willing, please perform the following test so we can confirm or eliminate this possibility.

This what pops up in console. 2% doesn’t leave a mark when fired on and when framing there is no mark.

Excellent, please test fire at 10% power (while wearing safety glasses).
With nothing else changing, if the laser dot shows then it’s likely in Calibration. If it doesn’t show it’s likely pin assignment.

It fires on at 10% all the way up to 20% when hitting fire button.

The pin out seems correctly assigned.

The Option codes are VNPR
V=Variable Spindle (or laser output)
N=Line Numbers
P=Parking Motion
R=Parking Override Control

More about that here:

The standard report requests should work with GRBL 1.1f

Please enter the following report request in the Console window in LightBurn:
then press enter. You’ll be able to select the text of the report in the Console window and scroll the text in that window. Please copy that report and paste it into a reply here.