Laser moves too slow

Hello, I posted this problem before and I have tried to solve it but nothing helps:

When I engrave an image in lightburn, the movement of the laser is too slow. This results in a darker and deeper burn of the image.
This problem lasts until it reaches 1% of the image, after that the rest of the image is fine.
This happens with my diode laser as well as my k40 laser. I have changed the board of the k 40 from nano to cohesion; same problem. I have changed the cables of the diode laser; didn’t help.
Also another laptop with more memory doesn’t change anything.
It’s always the 1st percent of the image.
The movement also changes when I minimise the screen (same problem). But that’s easy to avoid.
What causes this slow movement?
Thanks in advance,

What speed are you trying to use, and with what image settings, specifically DPI? What firmware are you running on the C3D?

The speed doesn’t really matter 300mm/s on the k40 or 100mm/s for the diode. Image is set to 254 dpi. Does is in greyscale as well as in jarvis.
I’m not sure about the firmware.

In short, you are hitting the processing limits of the hardware you have.

Unfortunately the speed does matter - If you’re using an 8-bit GRBL controller to process GCode, they have a limit of about 400 instructions per second or a bit less. A C3D controller running stock Smoothieware can handle about 800 per second, and running the new cluster firmware (or GRBL-LPC) pushes that up to about 2500 or so.

An image at 254 dpi means 0.1mm dots, or 10 dots per mm. If you run 100 mm/sec, that’s 1000 dots per second, and each dot takes a gcode instruction to produce.

Stock Smoothieware hits 800 instructions/second, or 80mm/sec with 254dpi.
8-bit GRBL is about 400, or 40mm/sec with 254 dpi

If you’re running GRBL-LPC or the new cluster Smoothieware (available on C3D’s forum) you can hit about 250mm/sec at 254 dpi.

1 Like

Thanks. I’ll look into that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.