Laser not connecting

I am a first time laser user. I am having trouble getting light burn to connect to my laser. I have tried connecting the laser to my computer both via usb cord and ethernet. I have modified the ip address of the laser per previous trouble shooting forum so that the first 3 sections of the ip address matched the ip address of my computer. I have tried saving a file that I want to engrave to a usb and plugging that in directly to the laser device and it cannot read from the usb drive. I have tried sending the file over the usb or ethernet connections and it tells me that the laser is either not connected, paused or busy. I have uninstalled light burn software from my mac and reinstalled. Deleted and re added the laser device. It is an Orion 60W with RUIDA control system. I figure it should not be this difficult to establish a connection to send a file to cut/engrave… thank you for your input and assistance with this troubleshoot.

You mention you are using a Mac computer. There are known issues with FTDI devices on MacOS, but there are a few ways to fix it - the simplest is removing the FTDI driver from the computer and letting the built-in MacOS driver deal with it.

For IP connectivity, we offer this post to help.

Thank you, but I do not understand coding and cannot get to “hardware/USB” to find the driver… I tried searching in spotlight, but nothing. I use MacOS Big Sur. I can do enough to get by, but coding/programming is beyond my expertise.

So for the youtube video I found, it is saying that FTDI is related to USB connections. I do not have my laser connected via USB. I have it plugged in now via Ethernet since that was the recommended connection to the device. I am quadruple checking my IP addresses now for doing the Ethernet connection…

For Ethernet, read here and see if any of this helps:

So I followed the instructions and it is still not showing Connected. :confused:

What is the IP address of your computer?
What is the IP address of the ruida controller? (as shown on the controller)
What is the IP address shown in the LightBurn “Devices” window?
What Is the Airspeed Velocity of an Unladen Swallow?

Nahh, you wont need to know that last one, but please report the IP addresses shown for the first 3 questions.

1 Like

lol goodness.

So for my Mac computer it is:
For the Controller I did:
And on the devices window of Lightburn it’s:


Or if you want the very original IP address of the controller the way it came, it is:

Well, your IP addresses seem reasonable. Are you connected with a cable directly from computer to controller or is this part of a network with “other devices” and connected through a router?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.