Laser not firing in frame mode

Hi I have an issue using your software . The issue is when I frame a project with my diode laser the laser does not come on in low power to outline the project. I can use LaserGrbl software and the same function works fine . I have enabled the FIRE button in the MOVE menu and it turns the laser on as expected . I also went through the Lightburn Forum and tried all the suggestions that I found there . If you could advise me it would be appreciated . I really like your software. BTW my laser machine is a Fox Alien 4040 with a blue diode laser.

Thank You

I believe there is another button that says something like “Fire laser while framing” or something like that. I had the same issue and if I remember right that button fixed it.

Depending on your version
Once you enable fire button, set 1% behind it
You must press SHIFT key + Frame button to enable it

In 1.0.4 you also have this option to be set as default on device settings

1 Like

I tried setting the fire level to 1% and had no luck. The version I am using is 1.0.06 .

Does laser fire when doing a normal job?
Try clicking the fire button so it enables, then slowlly increase the pwoer value, it wont let you go over 20% so you should be safe

Yes the laser fires and works fine during normal operation . I tried raising the fire percentage to 20% it still will not fire during framing cycle. Thanks for the help

In version 1.0.06 you need to hold Shift key while you click the frame button for laser to fire.

Did you try this?

Make sure Fire power is at a reasonable level before doing this.

Yes I hold the shift key down BEFORE I press FRAME .

Before or while? It needs to be held as you click the frame button.

If this doesn’t work, are you able to update to the latest version of LB? It may be easier to use the fire on frame option.

Yes I press and hold the shift key then press the frame button . I wasnt wanting to upgrade to the newest version of Lightburn but if it would resolve this issue I think I would do it. This is holding up a project for me .

Any particular reason why?

As a workaround, simply draw a rectangle or rubberband path around your design and assign it to a distinct layer with frame like speed and power. Then when you’re done, disable output and only send the main part of your design.

The main reason why I dont want to upgrade is I dont want to invest any more money into my laser machine til I use it more. Thanks for the workaround I didnt think of that !

Ah… didn’t realize you would need to renew. 1.0.06 was a fairly solid release so not a bad place to stay.

Can you confirm that framing with laser never worked or is this a new issue?

Also, please provide the following. There may be a configuration issue:

  1. Confirm that the laser is setup as a GRBL device. Go to Devices, click your laser, and check information at bottom of window
  2. Screenshot of Edit->Device Settings
  3. Output of these commands from Console:
    • List item

Ok the framing with laser has never worked.

Thank you for your help

i actually not certain and too late to turn my machine on
Is Fire button a M4 command or M3?

I believe older versions used to be M4 but was switched to M3 so that laser intensity would be consistent irrespective of speed.

Not sure what happened here but I don’t see anything.

In Devices Settings:

  1. You have auto-home enabled but the warning message indicates you don’t have homing enabled for your laser. Can you confirm if your laser has homing switches? They’re likely mechanical limit switches that activate with the head at the far left and front travel.
  2. You have Transfer Mode of “synchronous” configured. Is this deliberate? Generally you’d want buffered but some controllers require this.

You have an offset configured at 50,50. Is this deliberate?

Can you run this in Console and return results:


Do one last thing. Enable “Show all” in Console, then these things:

  1. Use Fire button to test fire laser
  2. Use shift-frame to test a framing operation.
  3. Capture output of Console and return here.

No I do no have homing switches . I went ahead and changed a few things per your suggestions.