Laser not firing on CO2 machine

I have a 300W CO2 machine with Ruida controller
I’ve installed the LB DSP version yesterday
The LB software recognizes two controllers when connected to the machine
Upon sending file to the machine and hitting start , the machine head moves with no laser emitted , but machine works well with an open source software (named metal cut)
Tried the LB software on my g-code machine and all went well

Hi Ali,
You can try to: Go to ‘Edit > Machine Settings’, then all the way to the bottom, unroll the Vendor Settings section, then look to see if Laser 1 is enabled. If not, flip the switch to turn it on.

1 Like

Hi Ali

Please provide a bit more information if you can:

  • What controller exactly
  • Screenshots of your EDIT > settings
  • Screenshots of your EDIT > Device settings

Full screenshot of your LightBurn with an open project.

I’ve already enabled both laser 1 and 2

This is my rd controller
Below is the link for the video showing the machine behaivor

Laser Settings

Vendor Settings

I am not familiar with this kind of configuration… But, I believe this is an LFS-PM-T43 which is the autofocus end of things.

This is the PDF manual… remove the .txt extension after downloading.

LFS-PM-Series-Live-Focus-System-Operating-Manual-V2.0.pdf.txt (2.7 MB)

IMHO, I think we should start at the lps end and work backwards… It would be nice to see what this device is controlling…

I suspect there is another Ruida in the mix…

You have both tubes enabled, does this have two tubes?


1 Like

I meant that the machine was reading both packet and serial
Tried to operate both, but still stuck in the same problem(machine moving but not emitting any laser)

Someone from Lightburn such as @Rick needs to advise on this… I have never seen this type of configuration, so I’m pretty clueless here…

I have no clue how Lightburn talks to two units, one being the laser controller and the other being the auto head adjustment…

Hang in there…


So will be waiting for @Rick

1 Like
1 Like

Please take a look at the information @JessN shared and let us know how you progress. :slight_smile:

How does this work with two Ruida controllers in the system? The photo seems to have them wired together…

Does Lightburn actually control anything with the focus module?


This is a step by step of my installation

Again ,I chose the Serial/USB but still having the same problem (Don’t know if something is missing in my driver’s installation)

Also to be noted
The machine is giving out air and moving along the path precisely with no laser emitted
Tried another software (named metal cut - it came with the machine) and all went well

Also tried to send file to machine , but still having the same problem(only air is emitted with no laser)
Is there any configuration that should be done in the software?

@Rick @JessN

Gathering the information shared, investigating further. :slight_smile:

Please share screenshots and a LBRN project file of the job setting where you do not get laser output.

Update: I missed the inclusion of the Live Focus feature of this setup. LightBurn does not support Live Focus at this time. Asking dev team for any additional information we can share.

Will share very soon (my workshop is closed - will be opening in few hours)

Did you meant that I have to change any settings for now? (IDK what is the live focus feature)
And what information do you want me to share exactly for you to investigate (I will share a video of a file that I’m trying to do)