Laser not working correctly on Original

laser is still etching while going to the next part of the design.


As you can see the etched lines of the jog between etch design.

Lightburn didn’t recognized my machine and as suggested I manually set my machine to Snapmaker, set the baud to 11500 and added the M3 and M5 commands to the start and end of the gcode.

Lol right now my trial has expired so I can’t get screen shots. any help would be greatly appreciated.

You shouldn’t need to do this if controller is set to Snapmaker.

Also, the photo you tired to upload didn’t work correctly. You may want to try again.

If I didn’t put in the M3 M5 commands the laser didn’t turn on or off

Also forgot to add that I’m using the USB connection to my device

Can you confirm that your device type is configured as Snapmaker and not Marlin or GRBL?

yes it is configured for snapmaker not marlin or GRBL

Sorry it should read as “configures as SnapMaker”

Also the design at the top of the photo, that design was etched by Luban. So I think that’s a good indication that the hardware is working.

I don’t know much about Snapmaker but instead of using M3 at start, can you try “M4 I” or “M3 I”? That should enable dynamic lnline or continuous inline mode respectively.

Is that an “eye” or a one

The letter. ‘I’ as in Inline.

Thanks with your help and I’ll try it tomorrow and let you know

Thanks for your help. It turns out I was wrong and lightburn was configured to Marlin. I switched over to snapmaker and it works well.
Thank you again for time and help.