Laser Offset not being used when framing

Hey there,
I have an Atomstack and I built a vacuum head to surround the laser module. I set a small red laser module in the front of the vacuum head as the head makes it hard to use the actual laser for locating. Because of this I have to use an offset of -45mm in Y and -2mm in X. However, when I go to “Frame” the job the offset is not used. Can someone fix this?

1 Like

How have you done this? Screenshot is helpful here.

If you did this with a pointer offset it should indeed account for this in framing.

Enable “Show all” in Console. Then run a frame operation first with pointer offset enabled, then with the pointer offset disabled. Does the Console output differ?

You mean this:

This is where I am enabling the offset, when enabled the offset is not used when framing. At least not for me.

1 Like

Can you run the test that I listed in the previous post and return the output? Curious to see if there’s any attempt at accounting for the offset.

I am confused. All I can tell you is when I go to the screen that I referenced in that copied link and I turn on the offset, it does not use that offset in framing. I can’t give you a screen shot as I am at work and the laser is home. But the offset is not used in framing. When it frames the part it ends up hanging off the back edge by 45mm and off one side of the other axis by 2.

When you say the framing doesn’t use the offset, are you basing this on the location of the red laser dot?

When you’re back at the laser, try running the test I’ve described.

One other consideration, is it possible that you’ve reversed the direction of the offset from what’s required? Meaning instead of negative values you want positive values?

I think I’m not being clear. I must not be.
This is the best I can do. If I ignore the incorrect framing path and just engrave the part, it engraves in the proper location.

Nice diagram.

What are you referencing to determine the path? Is it the red dot? Or something else?

The red dot is just an indicator to me as to where the blue dot will be when it starts cutting/engraving. If frame was running correctly the center of the laser (the blue dot) should move up to where my reference (red dot) was at the corner of the part (then trace the perimeter of the part). It doesn’t do that, when I hit frame it traces the frame from where the blue dot is (which is -45, -2 from the red dot). It does this weather the offset switch is off or on. The offset switch is currently ONLY affecting the actual cutting path, not the frame.

The expected behavior is for framing to be unaffected but for the actual output/laser to be shifted to match the area the red dot framed - is that what you’re seeing?

Yes that is what is happening, however, that behavior doesn’t make any sense when you are trying to use an offset laser to point to the origin of your program, but you want to see the ACTUAL path of the frame. Maybe add a switch (Trace Frame to Offset)


Perhaps I’m misunderstanding what you’re trying to do, but if you’re using the red dot pointer for alignment, it makes more sense that you would jog the red dot pointer to, say, a corner of a piece of material, and then frame from there. You are seeing the actual path in the most important sense. Where the red dot frames, the actual output will be.

If the behavior were reversed and the framing were offset, you’d need to align the laser beam location to the corner, then check to see if the red dot location was correct when the offset frame was run. But that would be a bit trickier than just using the red dot in the first place - for a diode laser you could use the Fire button to align the beam location (but then you probably don’t need the red dot to begin with), but CO2 lasers don’t have that option, so it would create some unnecessary guess-and-check.

1 Like

The vacuum attachment surrounds the laser module so seeing the actual laser isn’t feasible. That’s why I pick up the origin with the red laser. I would simply like a way for the frame command to mimic the behavior of the program if laser offset is enabled. Mainly as a sanity check to make sure nothing crashes. Just so I know for sure when I hit go, the head is really going to offset.

Gotcha - as long as you have the offset dialed in properly and never turn it off, when you run then job the head/output is always going to offset to the location you framed with the red dot. But I can understand the desire for an additional sanity check - to do that, you can turn down the power setting on your layers all the way to 0%. Then frame them, then run the job at 0% power, and you’ll be able to see that the offset is working, without risking any material.

As for changing the way the feature works and adding a ‘Trace Frame to Offset’ switch, we provide a site for users to vote for new features. You can search to see if this has been requested, and vote it up, or add it so others can vote their support as well. This helps us to prioritize which features to direct development time toward.

1 Like

Ok, I’ll send them that request. Thanks a lot.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.