Laser Power Fault

Encountered this issue over the weekend. Got a laser power fault error. Power cycling the machine did not seem to do anything (Fault still present after cycling the power) Checked the laser tube connections and nothing seemed off. Going into diagnostic menu ,then pressing the reset button in lower left of the control panel on the machine seems to get rid of the issue temporarily.

The first time this happened was this past saturday 7/24. after hitting the reset button the machine ran through multiple engraving jobs without issue until today 7/29, when it happened multiple times.

just some random troubleshooting notes in case it maters

  • when it occurs we are unable to pulse / test fire the laser
  • has not cut out in the middle of a bitmap scan/raster jobs (have run over 20 hours of machine time between 7/24 and 7/29)
  • error triggered during low power cut operations ( 15% power)
  • have not had to run a low power cut job since 7/24 until today 7/29
  • some time ago (about a year?) I noticed we could not set laser power below 15%. If the power in the job was set to 5% or 10% from the computer the machine will change it to 15%. We cannot manually set the power lower from the machine control panel (defaults to 15% if attempted to set lower) . We use these low power cut operation to put outlines onto paper that we lined the bed to assist with material placement. We have just increased the speed of the cut in the jobs to compensate.

Just short of the 3 year mark on this laser.

model: 1390
laser tube: F4(100-120w)
controller is RDC6442S-B(EC)


I just logged onto the forum to talk about a very similar problem that I am having.
I have the same controller as you have.
A few days ago I was in the middle of a scan job (after completing several others successfully) when the whole laser just stopped right in the middle of a part.
The arrow keys would not move the head, nor would the reset button on the display work. Although, the display did seem to still have power to it.
In the end, I turned off the whole machine and when I tried to restart, the PSU did not respond when I pressed the test button.
I removed the PSU from the machine and opened it up to have a look inside it to see if there were any obviously burn parts, but nothing was visibly wrong.
I then connected the PSU directly to the mains power, it lit up immediately and the test button responded appropriately.
I put it back into the machine and it worked properly for the rest of the day.
Next day, after a few hours work, the same thing happened, but this time, the PSU said it was still working properly, but the laser would not fire.
I am reluctant to believe that the laser tube itself is broken, as if that were the case, then I don’t think it would have restarted after the first stoppage.
Any idea as to what I should test to find out what is broken?
Is there a way to bypass the Ruida controller and just apply power directly to the tube?

my machine didn’t seem to lock up the way you’re describing. the machine stops and makes a alert tone. the control screen showed “laser 1 Power fault” (enter) (esc) and I think hitting enter causes it to attempt to restart the job (just errors out right away) hitting esc cancels the job and then I was able to move the head around with the arrow keys, but was not able to pulse the laser.

I ran into the issue a few times today, finished putting down my outlines and did multiple scan/raster jobs without issue for the rest of the day.

These are the most difficult things to fix. Anything intermittent is a crap shoot. If it’s not broke you can’t fix it. The only other option it replace a part at a time, usually at the lowest cost item… or your hunch. You are still back to running it and hoping you replaced the defective item.

I looked through the couple Ruida translated manuals (my Chinese is not too good) but couldn’t find anything about that power error. Nor does my Ruida (6442G-B) even have any way that I know of for it to determine the KV, if that’s what’s really displayed on the bottom of the power error display. Don’t see any extra place on yours, from the picture either.

IMHO the two issues are not related. However it’s always good to not assume anything if you can help it.

Good luck… :slight_smile:

This does seem odd. These controllers are pretty stable and I’ve never seen the reset button not work. I have to admit I haven’t tried it in the middle of a job, which I will :slight_smile:
Also never tried it during some kind of error processing…

Yeah I am unclear what the difference is between a power cycle and hitting the reset button . At least for now the reset is clearing my error

There is a major difference. For one thing if you can’t reset it from the panel, you have lost control of the controller. It’s out in never, never land… I’d say your controller may be trying to tell you something.

Power reset or console?

For my issue described in post 1, power cycling did not clear the laser power fault (error still persisted in new power cycle) , but resetting from the panel has cleared the issue (it still comes back later, but I have been able to run scan/raster jobs in the meantime without encountering it)

The symptoms don’t sound related and consistent. The problem part should show a consistent result from some action. I had an engineering professor tell me once, solve 1/2 the engineering by understanding the problem. I took that over into troubleshooting. So I’m looking anywhere I can to see if something is related and be able to associate it with a piece of hardware.

Usually a soft reset maintains some data compared to a hard (power on reset). It comes down to how was coded. Some controllers do the same exact sequence on power up as when a soft re-boot is executed. Some don’t and retain information. Ruida doesn’t tell us much about what goes on inside, like most other proprietary hardware and software. They ‘appear’ the same :slight_smile:

Maybe the lightburn people have enough of a connection to find out if the hard and soft resets results are the same.

Take care.

I just ran another test to try to get more information.
This time, I pressed the test button on the controller while actually looking at the tube. A bit of a contortion, but doable.
the laser turned on and burnt a hole in a piece of paper. So it isn’t either the laser nor is it the tube. That leaves only the wiring and the controller.
More testing to follow.

I don’t have a ‘test button’ on my Ruida controller, just ‘pulse’. I assume pulse.

Generally most of us think of the laser as the tube. Assume “power supply or tube.”

If the laser fires from the controller console, the controller is talking to the laser and it is working properly, along with the power supply. Unless it wasn’t working when you did this test, I don’t know what this gets you.

I think the main issue is that it’s intermittent. Unless it’s in a ‘fail’ mode you really can’t tell if it ‘just happens’ to working at that time.

You may end up swapping something out to really find the issue.


No, I made a mistake. I meant to say the button on the PSU.

It looks like you have some kind of intermittent controller issue. I cannot locate anything on that Ruida power fault screen. If you can’t control the controller, it must have an issue.

The only thing I could suggest is use a volt meter to check the PWM inputs to the power supply. Doubt it is an issue if it’s working locally. Keeps coming back to a controller issue.

What’s your gut feeling? Seems there isn’t a lot of choices.

Good luck :slight_smile:

Thanks Jack
The problem was the 6 pin plug on the PSU. That is why it looked as though it had to be the controller.
The plug was pushed firmly home, but was not making good contact.
Russ Sadler suggested a few test procedures and as I went through them I was getting stupid results and an ocassional laser fire.
I was trying to measure the voltage drop between the L and Gnd on the PSU and it was fluctuating between 0 and 5v. I assumed this was because I was not holding the test prongs accurately enough, so I braced myself properly and pressed on the plug and prongs at the same time, and it all worked properly.
I had removed and replaced that plug quite a few times in my attempts to find a solution, but when I pressed the test button on the PSU, it kept assuring me that it was all OK.
Russ told me “Next, you need to check the switching at the L terminal. With the machine ON but not running the voltage between L and GND should be close to 5vdc. When you run the machine that should drop to almost 0vdc to cause the tube to switch on. If it only drops to about 3vdc then the tube will not switch on. B grade power supplies often fail in this way. This switch is bypassed when you press the test button so you will never detect a problem.”
He was spot on!
I changed the plug over for a spare one which was on the Ruida controller and it started up immediately and it all worked perfectly.
Massive THANK YOU to Russ
Thanks also to others here who have looked at the problem even if they could not help.

Cool, intermittent problems are the worst. I’ve dealt with Russ, I have his lightweight head on my machine. He helped me with getting it straightened out. He’s a shining star for most of us that are new at this and I find I keep going back to his videos to work out issues. He must spend his waking moments answering email :slight_smile:

Now explain to me how the controller detected a ‘power fault’ from a control line intermittent.

Good luck, at least that headache is taken care of :slight_smile:
Take care.

So you moved the connections from CN5 to CN6 on the controller? (basically set up the connection for laser tube 2)

Actually I think he had a bad connector, he just replaced it. :slight_smile:

CN6 is the Laser2 control. I tried swapping the connection around to see if I could get it to work via the laser2 port. Thought it would add another tool for debugging. Got it to work, but lots of config changes in everything from Lightburn through the controller. Had to wire WP2 to WP1 or I got a water protection error.

What Jack said. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.