Laser shutting off about halfway through (yes, I've read ALL of the other posts)

Here we go again.

Having said what I did in the subject line, I’ve read the other posts and have done what has been said, this is getting ridiculous.

I don’t know about you but I don’t speak the language of “OZ”.

The basics: X-Carve with controller bought in 2020 with the JTech 7w laser.

Let’s try and assume I have a run of the mill laptop with Windows 10 (I do), every driver is updated and your software with a JTech laser.

Every single thing I try to use the laser for, it stops halfway through.

Solution?

Sorry for being terse, but when a software forum has so many of the same and different issues, you’d think there’d be simple bullet points of trouble shooting covering most issues instead of typing so many keywords into Google to find a solution.

I’m losing time and money.

Please, I’m begging here.

So now that you’ve read ALL of the other posts (I’m impressed}, what solutions have you actually tried and what were the results?

Can you provide any more information besides “shutting off about halfway through”?

I’m detecting the sarcasm and I can appreciate it, truly.

As I’m writing this sentence another few lines of text just stopped on the laser.

If I upload something and image trace it…or write a few lines of text…or literally anything…it just stops after a 2-3-5-8 minutes but never actually finishes the burn.

I’ve disabled the USB power management setting (one of many of the previous posts).

What else is out there?

You don’t get any error messages, it just stops?
Have you tried a different USB cable? Preferably one with ferrite chokes on the ends?
How long is your cable?

6’ cable that came with the X-Carve. My laptop is approximately 16.37" from the controller.

The console says:

As if it’s still running but it’s not.

If the chokes are important it should be a damn fail-safe requirement.

No joke, I sincerely appreciate you responding. Slainte!

Any ideas?

If it looks like it’s still running, but it isn’t, that will be a communication dropout of some kind.

  • Is the frame of your laser grounded?
  • Have you verified that USB selective suspend is disabled for the USB ports?
  • Do you have anything that could surge connected to the same outlet or circuit as the laser? (mini-fridge, compressor, chiller, table saw, etc)
  • Have you tried a different USB cable?
  • Does the USB cable run close to motor / stepper wires? (those are relatively high current and can induce noise in unshielded cables)

As for the “many other posts”, I’d bet that if you look closer you’ll see that nearly all of them are from Ortur laser owners. Those systems have no grounding and customized firmware, both of which seem to be contributing to the issue.

FFS. Since of today i’m facing the same issue with my Orut Laser Master 2.

@LightBurn you said

“As for the “many other posts”, I’d bet that if you look closer you’ll see that nearly all of them are from Ortur laser owners. Those systems have no grounding and customized firmware, both of which seem to be contributing to the issue.”

so what’s the solution?

EDIT: As i found in this post (Engraving a picture, laser shuts down in about 3 to 4 minutes) the Ortur Lasers are not grounded and that is the reason for the laser to suddenly stop on a job.

Anyone knows how to ground it?

Attach a wire from a metal part of the frame to a grounded object, like the case of your computer. The plastic wheels will isolate the different frame parts from each other, so it might be necessary to ground both the laser head, X axis rail, and main rails independently by tying them all to a single wire, then connecting that wire to ground.

The grounding issue: I had taken off the hose and metal mount which had a grounding wire attached to a metal outlet box. I put it back on.

Started burning the same image again…seemed to be going well then it stopped again. It went further but still stopped.

This has been a lot of fun, hasn’t it?

Actually, looking at everything…the grounding makes no sense when it comes to grounding the frame. Nothing about the laser itself touches or is connected in anyway to the frame/rails. Just the wires that go back to the X-Controller. Unless you’re talking about connecting a wire from the GND from the back of the X-Controller to the Y rail…then somehow to the X rail then somehow to the Z carriage…then still there’s nothing to connect it to the laser itself. The plastic V wheels prevent any metal contact between any of the rails. If this was an issue then wouldn’t a company like JTech include a grounding solution? Or better…wouldn’t LightBurn have that as one of the simplest solutions from the get-go?

When Googling stopping, halting (pick any adjective) I haven’t seen anything that has worked yet for me. I’ve had the laser/X-Carve and Lightburn software for about 6 weeks, using when I can, and this all just really sucks. I hope you can understand my frustration.

At this point, I’ll offer money to have a Go-To-Meeting screen share/a webcam with someone from Lightburn to figure this stuff out.

Awesome, just ruined a piece for a customer. It worked twice on a piece of scrap then put a finished piece in…stopped halfway through. Also, having problems returning back to the original position but I guess that’s another forum post among dozens and dozens of others. (tried past post solutions and no dice).

The X-Carve (and a number of others) use rubber belts moving over plastic wheels, and that will generate static electricity, and if that discharges through the USB connection, it can cause dropouts. The fact that the laser head is isolated from everything else is precisely what would allow static to build up. I can’t say that is the issue, but it’s one that’s come up before.

Running GCode for images is really pushing the limits of what an 8 bit controller can do, so if you’re doing photo engraving, if anything is going to go wrong, that’s when it’s going to happen - the amount of gcode sent to the controller is a fire hose compared to the trickle of a normal cutting or engraving job.

If Easel can run external GCode, try this: in LightBurn, click ‘Save GCode’ and save it to a file, then try running it from Easel. If that works without any issues, then there’s a decent chance that there’s a difference in the way that Easel and LightBurn communicate with the machine that could be an issue. If it fails in Easel as well, then it’s probably not LightBurn at fault.

Regarding the starting point, if you use ‘User Origin’ or ‘Absolute Coords’ mode with a properly homed machine, your starting position is remembered and can be re-used. If you’re using ‘Current Position’ mode, all bets are off.

(literally pulling up my sleeves to type)

OZ, (am I talking to a person or a company?). I love the speed with which you reply. But…

Let’s get to resources for LightBurn: $40 is to cheap for a ubiquitous software for use for many laser machines/buners/etchers/blah blah blah to run on…hence (probably) the issues. Charge more! When someone, like me:, spends $1,000’s on a machine…a $40 software will undoubtedly have issues. I’ll gladly pay over $100, in order for your company to purchase the machines, assemble them and do what virtually most customers have to go through. And THEN be familiar with the issues if and when they pop up.

Now, to the grounding and static electricity build up on the rubber belts and plastics wheels?! That whole first paragraph to me says that no one knows that the “F” they are building and selling to customers with respect to a grounding issue for something that runs on electric. Yes, it can have a grounding issue, but that presupposes that every laser, machine and software figured that before selling the product.

About Easel: How can I run Easel to run the laser? (rhetorical)

So here’s what happened tonight: I restarted my laptop 3 times, opened up LightBurn about 3 or 4 times…I finally connect and get it to burn. (had it run twice line/fill) and it worked. IT WORKED!

Now, I’d like to walk into my shop…open up the laptop and turn the X-Controller on, and the JTech driver, click start and burn.

BTW, through all these issues, I decided to not have my Chrome browser open, incase of “something” with Easel. But if that’s the issue…are you kidding me?

Also, you might notice that it started going over the same line over and over and over again…another issue?

Is your fan operating / spinning at all times?. It might be something simple like a short in the fan, or the fan is clogged with sap / dust from the wood. You said you have only had it for 6 weeks, so there might not be much build up. Might be worth contacting jtech and get instructions for testing fan for a short.

1:46am while I’m typing this.

I opened up chrome to write this.

Tripled the size of the logo just for sh*ts and giggles…and to test…

so far so good. (messed with A LOT of settings where I don’t know what they do, ‘Konami Code’ type of sh*t)

The one thing I changed so far is…

I got rid of the IOT relay and plugged everything into a 3 outlet extension cord: X-Controller, DeWalt 611 router and the JTech driver. Nothing was ever mentioned about an external relay switch product in any forum I’ve seen.

It’s still going!!!

If I’m right…then throw this thing out and don’t ever buy it!

Let’s see how this night goes!!! I’m staying positive!

Also, “OZ”, IF this is the solution…you owe me a nice bottle of Bourbon (an IOT relay or a relay switch product with an X-Carve or similar machine was never mentioned that I could see in the past forums)

Progress since typing this…(2:09am hedging my bets, so far so good! It doesn’t burn fast but it is what it is. Any tips on speeding this up???)

2:17am LONGEST IT’S EVER RUN!!!

Like I said, triple the size, maybe slightly more.

I have to work in the morning to respond to engineer’s comments for a research building that I’m working on but this is holding me in suspense!!! (my full time job)

Yes, I’m writing all of this live without actually hitting “reply” so I don’t put my foot in my mouth…

2:26am…still going…

Listening to some 80’s music…“Hungry Eyes”…because…ya know…

Progress…

2:52am…still going and still happy (Seagram’s Vo/Diet Coke doesn’t hurt while listening to “In Your Eyes” by Peter Gabriel…again…I’m watching this whole process with my eyes to prove something…determination for us customers out there!!!)

I’m still holding out hope that the fact I bought this IOT relay and used it, is the sole issue that I and many others have had. (is this the issue?!?!?!?)

Now listening to “Missing You” by John Waite…I’m missing you, “OZ”!!!
(this is a 16"x 10" burning)

DONE!! (3:36am)

It didn’t stop halfway through…but it kept going until I hit the emergency button to shut it down. Don’t know what happened there!!!

The IOT relay definitely made a difference.

Let’s chat…

I had basically the same situation… laser stopped randomly with no error… just stopped… I’d re-home and try again and it would stop in a random different spot… increasing the size seemed to help… turned out I had my micro step at 32 and I changed it to 1/4 step and that fixed it… must have been over my clock rate…

I have my Tesla charging on the same circuit as my laser and have been having problems sending data to the machine. Is it possible that you aren’t getting enough power?
Perhaps try the cuts on low power so laser doesn’t fire and that will give you some data to work with.

Also, at some distant time in the past I found that the machine would do random things and I was lucky enough to see a spark in the cabinet where a wire had been routed around one of the bolts of the adjustable legs. It had worn through and would short out during the job. Maybe??

Person - Real name is Jason. When I was still working a day job and didn’t want to be public about my side gig, one of the beta group members started calling me Oz (‘The man behind the curtain’) and it stuck. I still use it, mostly to keep people from harassing me personally through direct messages rather than using the support channels, and also because of the “in-joke” status.

My question was “can Easel pass GCode directly to the machine?” - As in, save the GCode emitted by LightBurn and run it from Easel. If Easel or another GCode sender gets through the whole job without issue, running the exact same GCode, that would be a strong indication that the fault is mine, but if it had the same issues, it would indicate the opposite.

Stranger things have happened. Chrome is a memory hog, and some pages can be CPU hungry. The worst effect that should have would be reduced throughput to the machine.

As part of the engraving itself, or part of the ‘Line’ mode that followed? If it’s a continuation of a single engraving, and the Y axis stopped advancing, that would suggest a loose wire to the Y axis stepper driver, or Y motor.

I don’t think the price of the software is related - These machines aren’t that expensive, and the fact that they’re DIY / self builds opens them up to all kinds of issues that have absolutely nothing to do with software, as you’ve discovered. Electromagnetic interference and static build up are both common with CNC systems, and nothing I do with the software is going to change that. We have set up a number of machines for testing, but everyone’s build will be different, and most of the issues we see end up being mechanical, electrical, or firmware. I’ll never say that LightBurn doesn’t have bugs - it does, and we work hard to fix them - but the lion’s share of posted issues aren’t the software.

Go to Edit > Device Settings, enable ‘Fast Whitespace’ and give it a reasonable speed to use for traveling over the blank bits. If the engraving shown is vectors, I’d select the outer ring and split it into a left half and right half, then set ‘Fill shapes individually’ in the layer settings. That will eliminate nearly all the whitespace traversal.

1 Like