Laser stopping half way through burn

I am running a Ortur LM 2 15w. I have tried to engrave an image 3 times now and every time I run it, the laser stops about half way through the run and then starts again in a different area, completely messing up my image.

Can anyone offer and help or ideas how to fix this?

I did check the belts and they are good, not slack in them

Hi I was having a simular problem and tother members said it might be the usb lead or my laptop, I should have only done one change at a time to see which one it was but i didn’t did both.
so what I can tell you is the usb lead that came with my ortur LM 20w was really lose so i tried another one which was a better tighter fit both ends. maybe didn’t need to change the laptop but it was getteing a bit old like me lol.

Hope this helps

Sorry forgot to say it did cure the problem and is now working fine.

Also, look for signs of what might have happened. For example, keep the Console tab open and stop the print after the failure than scroll back to see if you see anything in the Console which would explain the stoppage and restart.

There have been changes to lightburn to handle intermittent disconnects and could be why it now doesn’t just fail and stop but restarts with a lost home position.

As mentioned above, bad USB cables are a bane for laser cutting/engraving and especially so during engraving in fill mode as it streams lots and lots of gcode over the usb cable to keep up the speed.

Also know, the Ortur’s have an accelerometer built-in so if things move around too much it’ll stop. It used to just stop and require a reset.

I am going to pick up a new cord at Walmart tonight and see if that helps.

Also, I forgot to say that I saw a “Alarm 3” code when it stopped working

minor details… LOL

Did you look up what “Alarm 3” from a GRBL controller means? Hint: grbl was reset during motion.

ALARM:3

Reset while in motion. Grbl cannot guarantee position. Lost steps are likely. Re-homing is highly recommended.

I dont know what to do besides return this thing at this point

now you know something is either glitching your power supply, there’s a loose connection(connector) or the actual power supply flaky or could even be noise on the USB cable. Lots of things it could be besides the device itself. Start checking cables and all the things listed. Also try running from laptop running from battery power so there’s no chance of a ground loop on the USB cable connection…

They do? Where is it? In the laser head?

There isn’t, anyway. The power in to the laptop goes through a transformer before arriving at the laptop as DC.

It’s not possible for there to be a ground loop.

no, not in the laser head… there are ONLY 3 wires there, PWM, GND and 12V…

So an accelerometer attached to the chassis is going to be real useful.

Maybe it doesn’t have an accelerometer.

As far as I can recall, there’s no code in grbl for accelerometer reading and analysis.

take your machine and smack it on the side while it’s running a design… The LM 1 has them and if you don’t bolt it down and move too quickly, or you knock the table while engraving it’ll stop.

BTW, they do not use stock GRBL…

1 Like

Interesting. I wonder what their use-case was in the design meeting :slight_smile:

Probably safety - cuts the beam if anyone moves it

My apologies for questioning it. I’ve not come across it before.

1 Like

I’m having the exact same issue running a K40 on GRBLHal on a Teensy4.1. Basically while doing an engraving it will stop for a quick second and then start up again where it left off but in a different position. I can tell you that the Alarm 3 is likely not your issue. The Alarm 3 is being thrown when you press the “Stop” button after the job fails. I confirmed this by pressing the “Stop” button during a normal job that didn’t fail and it also throws the Alarm 3. Watching the console, when the glitch happens the controller doesn’t report any issue. That and the spurious nature of the problem has got me quite frustrated. I’m thinking it may be a result of communication through the USB getting garbled causing GRBL to throw out a set of unreadable instructions and then pick up again on the next readable instruction. Since raster g-code are all relative moves it doesn’t go to an absolute position when it picks back up. I’m hypothesizing here. Let me know if you have figured out the issue.

Hopefully you’ve gone through all the things to eliminate USB cable/signal issues.

What computer OS, are you rastering( as opposed to lines ) and have you tried cutting speed in half and verified it still does/doesn’t happen?

I have not figured out what the issue is, but it is really irritating that it keeps happening. I tried using my laptop and my desktop and it happens either way. I am running windows 10

I have ran from 1200 to 3000 and I happens regardless

Did you replace your USB cable with a top quality shielded and ‘choked’ cable?
Did you verify your computer and laser are connected to the exact same AC power outlet?
Did you verify your USB connectors are not loose or in any condition which can cause a poor connection?
Have you tried using a powered USB hub between the computer and the laser? Again powering all from the same AC phase(outlet)?

On the Window side, you’ll have to google for all the things which Windows does to your USB port like powering it down, probing it for virus’s, etc etc.

if you know Linux, make a bootable USB thumbdrive of Ubuntu 18.04 and run Lightburn from that and see if the problem goes away. If not, it’s still a hardware issue, otherwise a software/OS issue.

that looks like you more then doubled the speed instead of lowering it. Is 1200 and 3000 speeds in mm/min?