Laser stops during scan, Lightburn shows laser is busy

Hey everyone. Thanks for taking the time for my problems. I am having 2 issues with my K40. I dont know if they are related or not. I have the cohesion3d board upgrade, running Lightburn.
My first issue: laser will home without any problem, but it seems to lose all track of where it is after this. (I have origin set to bottom left in settings) if I dont manually move laser to the center with move arrows, it goes haywire when I start the print. By haywire, mean it moves to the right and tries to move out of bounds and of course the stoppers start making all kinds of noise as it can’t continue in that direction.

Ok, I move laser to center, and run a test on a scaled down version of my print. Runs fine. Scale it up and change my material, and start the laser. Runs fine for a few minutes, then the laser stops moving (no firing of laser at this point either) Lightburn says laser is busy, and continues until it thinks it’s done.

I tried a new usb cable…powering everything down and rebooting, but didnt help. Laser fires ok after this occurs, so the tube seems fine. (I have machine set at 50% power and change settings in Lightburn according to my print) I should say too that it doesnt stop during a cut (or line) only scan (or fill)

Sorry so long winded. Any advice? (I tried to upload a short video showing lightburn screen saying laser busy and the laser not moving, but was it has unauthorized extension and couldn’t upload)

This sounds like USB connection issues, relatively common with your setup. Go through the suggestions here and see if any of these resolve the issue:

For the starting point issue, make sure you understand what the various Start From modes are and how they interact with the Job Origin setting - there’s a good chance you’ve changed those without realizing what they do. For that, read here: https://github.com/LightBurnSoftware/Documentation/blob/master/CoordinatesOrigin.md