Laser stops in middle of job, Lightburn still streaming

I was about 25% of the way through a 70 minute project when the laser just stopped moving, but Lightburn said it was still streaming. I jad just upgraded to Lightburn 1.2.01 today. I had this problem with a different laptop, but this laptop had never done this with 1.2.00. I run a K40 style laser, 80W that originally had an m2nano board, but it has been replaced with a MG3 board from AwesomTech. I engrave rolling pins, and have done over 70 using the previous version of Lightburn without problems. How do I go back to the previous version?

1 Like

It’s unlikely an issue with the update but you can downgrade by uninstalling and then installing the older release from this site:
Releases · LightBurnSoftware/deployment · GitHub

Your preferences file will stay in place even after the uninstall so nothing to configure again. You can get rid of preferences if you want a true clean slate.

Nice Aussie native flora and fauna engraving in the rolling pins.

Are they for decoration or are they still able to be used?

tom_1, they are functional, mostly intended for use on clay, but can be used on cookies or pastry.

I wondered if my laptop and the USB settings may be the problem? I looked on line and found I can set the settings so the laptop cannot “sleep” the USB to save power. Perhaps that might help? I’ll give it a try before reverting back to the previous version.

1 Like

USB sleep or your laptop going to sleep could cause this scenario.

I had found much earlier not to let the laptop sleep! :slight_smile: :rofl: I had that setting sorted!

Are you an Aussie too? I’m in Mackay, Queensland.

Yep. Tassie.

As well as the operating system sleep settings did you check the Device Manager (windows key + x) USB device properties?

Uncheck the “allow the computer to put this device to sleep to save power” setting, if it is there.

Yes, I have now. We’ll see how it goes. I grew up in Hobart, came up here first year of High School. My parents were from here.

1 Like

Ive just started getting this issue, using a MacBook pro.

Ive stepped back a release in software and will try that as i never had the issue before.
using sculpfun s9.
I will report back tomorrow.

I changed the settings on my laptop so the USB port would not “sleep” and it stopped. Have had no problems since but it’s only been a couple of days. Try that first.

i downgraded software and it did exactly the same, im now trying to find out how to stop my usb ports from sleeping on a MacBook pro laptop. TBH this did happen after an upgrade in from Apple. I will report back on if i can fix this. LOL

Hi. I had the same problem on windows. I disabled USB selective suspend setting in Power Options but it did not help. To fix this issue I had to add a new DWORD Value to registry edit as described here: How to Fix or Use USB Selective Suspend Settings on Windows 10 - WinBuzzer

It happened again today, twice. But I noticed something. Today we were having weird power fluctuations - fluorescent lights were flickering, etc. Every time the laser stopped dead but Lighburn said it was still streaming was when the compressor kicked in………. ?

Noisy electrical circuit is one of the primary causes of these type of issues. Try to get the laser on a separate circuit from air compressor. Or potentially putting the laser on a UPS might even out the power enough to avoid issues.

1 Like

Excuse my ignorance, but what is a UPS?

Ok, looked up what a UPS is. What size should I get, and what type? Thanks for your help.

Since the purpose of the UPS would be to smooth out the power delivery you could get away with basically any size. If you wanted to actually use the UPS for the purpose of continuing a job during a power outage you would have to calculate it by determining the power draw multiplied by the duration of time you would want to be able to run. There are online calculators for this.

I bought one today, so I’ll report on how it goes.