Laser unlocked notice

why am i getting this message
[MSG:‘$H’|‘$X’ to unlock]
[MSG:Caution: Unlocked]
my setting is at absolute coords

Your controller is locked when first connected and requires to be unlocked to operate. This is just letting you know of the state of that lock and doesn’t pose a problem.

so how do I fix it because it doesn’t move

Is this a recent issue or this is the first time you’re working with the laser?

Can you provide some background to this and what exactly you’re attempting? Try to be as descriptive as possible please.

1 Like

This is recent. I was using an ortur rotary yyr and when switching back I got this message. All I did was reverse my settings from setting it up

it was changing the soft limits and the homing cycle from false to true in machine settings

What are you trying to do now that’s not working? What are you attempting and what happens instead?

Can you take a full screenshot of LightBurn as well please?

I am just trying to get back to engraving but the laser won’t move instead it comes up with this notice

Can you capture the other messages from Console? Looks like there may be something else there.

When you say it won’t move, what exactly are you doing at that time? Have you tried jogging controls? Do those work? How about framing?

When you first turn on the machine, does it home as normal?

What I am trying to do is frame my project and even try to print it. When I turn on the laser it jerks twice and stays in the spot where it was left. It does not home even though I have the setting set to do it. I have tried framing but get the error message I am sorry, but I don’t know what jogging is

Looks like the actual issue is that it can’t home or there’s something else fundamentally wrong. The “unlock” message is just the last thing to show.

Jogging is using the button in Move window to move the laser head. Are you able to use those controls and move the head that way?

Can you confirm that you have the power supply connected to the machine and that it’s getting proper power?

Can you enter ? in Console several times and then return results?

Homing Cycle enabled has bunch of constrains.
First of all, it will stay in Alarm or “Locked” state till successfully homed or got $X command. This is intended behavior of GRBL.

For Homing cycle to work you need to:

  • Have working home switches.

  • Have properly set homing direction

  • Have proper signal polarity (normally open or normally closed home switches.

  • Sufficient pull-off distance, usually 2-5mm

  • Proper table size.

So, it is not enough to JUST enable homing cycle.

The laser will not jog the power is on

“Pn:PYZ” meaning your Y and Z homes not cleared after home-and-pull_of. (P is a probe, does not matter). Normally after pull off all homes are cleared. Try increase pull-of further, from 3 to maybe 5mm?

You may have mechanical or electrical problem or your home direction is messed up.

I suggest first save all your settings from “$$” command, then reset all to defaults. Your firmware appeared specific to your machine, so defaults expected to be proper. Reset to defaults may help: “$RST=$” (Restores the Grbl settings to defaults.)

Compare your $$ settings save with defaults.

sorry you are talking with a lamen how do i save the $$ and load them back

I see you have console open. Just type “$$” (no quotes).

You will have long dump. Select all and copy save.
Then issue command “$RST=$”, this supposed to restore factory defaults. (above you just saved copy, just in case).

After that try to home by command “$H”.

If works - you maybe curious to compare, so do new settings dump and compare to what you had before.

To check if home switches are working, I hope you can identify them. Move gantry to the middles (may have to turn power off for that, then make sure power is on)

LightBurn or any other software periodically pull status. You may also do that in console or terminal. the command is just a question mark: “?”.
report looks like this:

In any state of the machine you may actuate home switches by hand and see the status (red markup above). You should see corresponding home letter when switch is pressed and no letter when switch is released. Any other behavior is indicative of settings or hardware problem.

That worked you’re a life saver. I just upgrader to a ortur master 2 pro. my wife would have killed me if I couldn’t get it to work. Thanks to all

What worked? Defaults?

yes it was defaults