Laser won't fire, but worked yesterday

Hey All,

I have a 60W 4060, RUIDA RDC6442G, I ran it yesterday doing some engraving that was about an hour straight that turned out great. I have a water chiller that was working and kept the temp consistent. I have a Milliamp gauge as well so I generally keep the laser in safe ranges to not over work the laser. Bought the laser new direct from China 2 years ago. I had to replace the Power Supply last year. Overall hobby type usage on it and the tub. Yesterdays 1 hour session is probably the longest at any one time.

Today I went to do some more engraving. Machine acts as though its working with the movements, but laser isn’t firing. Milliamp Gauge is showing power variations, so it seems power is working. When I noticed it wasn’t firing, I shut it down and rebooted the machine and everything. Same results. I then tried the Pulse button on the controller and still no dice.

It’s not at all acting like it did when the Power Supply stopped working. So I am thinking maybe the Tube is shot… which is odd with such limited use. But I am hoping it isn’t. Can anyone recommend anything that may help in my situation? Much appreciated!

Cheers,
Brett

Can you post a pic of the ends with the anode and cathode?

Hey @LaserWillie here are some images I hope they are decent.

Some added info. I did a pulse with a piece of wood in between the tube and the 1st mirror, and it made a burn on the wood. If the tube was blown, would it do this? Lens and the mirrors are clean. I didn’t have time to check alignment tonight, but it was aligned yesterday during the run time. I will double check alignment tomorrow, but weird that it would be out so much that it wouldn’t hit the lens.

Thank you!

When you get burned wood after the tube before mirror 1, there is hope ahead. Maybe your lens is broken or one of the mirrors is out of alignment. When your ammeter gives a correct value then your power supply or tube can hardly be broken. You have to start troubleshooting.

1 Like

I’d also give everything a good cleaning and inspection. You could also have a burnt mirror.

1 Like

If the ma meter is showing current draw, the laser is probably lasing.

Since you can toast something in the beam path, you have, more than likely a dirty mirror or lens. Did you clean it after it’s ‘marathon’ 1 hour run? An what were you doing during that run, something dirty?

:smiley_cat:

Hey All,

An update. So after checking all mirrors for alignment today, mirror 2 was way off… and it was missing mirror 3 all together. Can’t explain how that happened, with not using it since the last successful print, but it happened. So did a full alignment and now all is working. Thanks to everyone that took the time to post! I am thankful it was alignment and not a blown tube.

3 Likes