Laser won't position and makes loud vibrating noise

I’ve been able to engrave a few things but I constantly run into the laser moving into the frame and vibrating loudly. I have uninstalled lightburn more than once. I have removed the device and added it again. I have watched several set up tutorials to make sure I’ve done it all correctly and I am still having the same issue.

What are you using for your coordinate system in Start From in the Laser window? If you’re not using Absolute Coords I suggest you do so.

Also, are you following the procedure to turn on the laser while the laser head is in the front left? If not, you need to do so in order to establish a proper 0,0 at the front left of your frame.

Once you do these 2 things you should be able to proceed without crashing.

If you are already doing these things can you take a full screenshot of LightBurn with a design loaded and ready to burn?

1 Like

I have done those things and I believe I have the settings as you mentioned. I just can’t figure it out. I have to be doing something wrong.

Are you aware that the bottom portion of LightBurn is not displaying on your computer? This is not the cause of the issue but it can be disorienting and restrict functionality.

This is because your vertical resolution is lower than the minimum required.

If this is your max resolution I suggest you regroup all your tabs on the right to a single pane to remedy this. As in move your Laser window up.

As for your original issue… Run a few tests to make sure things are otherwise working correctly.

  1. Power-up your laser with head at lower left. Check the “Get position” button in Move window. Record the value here.
  2. Use jogging controls to move to upper right. Again check the position and record her.
  3. Do you hear anything odd from the motors while jogging? Is the motion smooth and confident? I suspect your belts may be loose causing steps to be lost.

6 posts were split to a new topic: Sculpfun S9 - Machine crash, vibration noise on startup

Does it happen on startup every time?
Does it happen mid-job?

Do you own a rotary attachment?
Any error messages in the Console window in LightBurn?

Did you ever figure out the problem?

I had the same issue after a couple of days. I found out that one of the pins on the X-AXIS motor was loose and had a bad connection. After setting the pin correctly it has worked fine.

Check with the manual move buttons which direction you get the vibrations. For me it worked fine up and down on the Y-AXIS, but vibrated or went in the wrong directions when trying left or right.

1 Like

I think you may try to change the “Job origin” position and see how it goes. Also in the “Edit” and “Device settings” menu. For me with Snapmaker Rey it was the reason.