LaserPecker 4 Compatibility

Has anybody gotten Lightburn to work with LaserPecker 4? I have loaded all of the files in the instructions from LP4 but Lightburn still doesn’t work with LP4.

I don’t think I’ve seen any positive confirmations from LaserPecker 4 users. But the manufacturer made a fuss about the new LightBurn compatibility so I’d hope it would work.

Can you describe in what way it doesn’t work? Where do the instructions leave you and what’s preventing you from moving forward?

Is there a link to the instructions?

The instructions are at:

The LP4 seems to connect but with an error message. Frame and start appear to cause the LP4 to disconnect and then reconnect but other than that, the LP4 does nothing.

The Console on LB reports the following:
EEPROM read failed. Reset and restored to default values.
Welcome to LaserPecker
Starting stream
laser 450nm
Stream completed in 0:01

How does the disconnect and reconnect manifest?

The Console output doesn’t look inherently like a problem.

Can you provide the following:

  1. full screenshot of LightBurn with design loaded and ready to burn
  2. screenshot of Edit->Device Settings
  3. Run these commands in Console and return output:

The first command should home your laser so be prepared for it.

I noticed that Lightburn reports that the firmware version of the laser pecker is 6.5.2 however the firmware version from the LP4 app on my phone reports the firmware to be 6.5.3. The LP4 is supposed to work with Lightburn only with 6.5.3. Something appears to be wrong with the firmware in LP4. I would try to re-load the firmware but there appears to be no way to do this after it is done once.

As soon as Lightburn connects to the LP4, the fan comes on but does nothing afterward. Attached are the files you wanted to see. The LP4 does nothing in response to frame or start.

1 Like

You included a screenshot of Edit->Settings. Can you upload a screenshot of Edit->Device Settings?

Also try these things and can you report back the results:

  1. Switch “Start from” mode in Laser window to “Absolute Coords”. Then test framing. Does that change anything?
  2. Increase the power level in your cut setting to at least above 10%. Does that change anything?

By the way, that’s not LightBurn reporting the version. That’s coming from the controller reporting its version. Not comforting that this is inconsistent in any case but I’ll assume for the moment that it’s just a labeling mistake in the firmware.

From what I can see LightBurn is basically communicating to the laser. The laser is just not doing anything obvious in return.

The LP folks said they have a fix but they have not told me what it is or sent it out yet,

1 Like

Hello, I have the same problem as you. Have you found a solution?

No. The LaserPecker support keeps telling me that LP4 works with Lightburn. I did notice just today that the LP4 firmware in their instructions is reported by Lightburn to be V6.5.3.04. My Lightburn reports V6.5.2 but the LP4 app reports 6.5.3. I assume that the LP folks have updated the firmware to V6.5.3.05 but when I try to update the firmware, I get a message that “the software is up to date”. Ill keep getting after them and if I get a solution, I’ll let you know.

1 Like

Any compatibility that the LaserPecker folks claim is entirely on LP (for now) - we do not have any of their devices on hand ourselves at this time, thus can’t confirm.

1 Like

Thanks for the quick reply, I hope this gets some solution in nearest future… I hope :slight_smile:

Oh, this is not very good news … but we hope everything will work) Thanks for the feedback!

It might be helpful if you contacted LP support and mention people are having this problem. Their support believes LP4 works with LB. When I first reported this issue, they responded and said they had fixed it but did not notify me of any firmware revisions. On the offhand chance that the firmware was updated but nobody told me, I tried to re-load it following their instructions, and I get a message that my firmware is up to date.

1 Like

I was just contacted by the LP support. I was told the problem was that I was using a “cracked” copy of Lightburn, and LB anti crack feature was preventing LP4 from working. I am not using a “cracked” copy, and just recently paid my renewal fee.

The LP support response is absurd. Not only do I have a legal up to date copy of Lightburn, I’ve used it on three other laser engravers (all Chinese) with no issues.

If anybody at LB is paying attention to this post, it would be appreciated if they would contact and tell them that the problem is not with Lightburn.

On looking into the problem with LP4 not working with LB, I noticed that LP4 identifies its firmware to LB as V6.5.2 which is not LB comparable. The LP app identifies the LP4 firmware to be 6.5.3 when it should be The LP app will not let me update the firmware because it says the firmware is up to date. However, I found that the first thing LP android does when booted up is “phone home” and the firmware version reported is NOT from a query to the LP4, but from somewhere in the “cloud” . It appears that the problem with LP4 and LB is either the firmware V6.5.3.04 was not loaded due to some error and the firmware in the LP4 is actually still V6.5.2 (which it was shipped with), but the file on the cloud recorded that the firmware update was successful so I can’t try to load it again, or there is a ROM or hardware issue with the LP4. My LP4 is from Kickstarter and one of the first shipped so a ROM or hardware issue is not out of the question - they did ship it with firmware not compatible with LB. To date, it appears that the LP support (actually, the folks at LP who actually know what is going on) are stonewalling me. I’ve provided them with a copious amount of data verifying that the issue is with either the LP4 hardware or software, and, as I mentioned in my previous post, they insist the problem is with LB.

All that being said, I don’t intend to badmouth the LP4. I love the machine. It is just that it (at least mine) is not Lightburn compatable as advertised, and I’m stuck using LP Windows Design Space software which is buggy and not near as comprehensive as Lightburn. It may get better with future updates. The good news is that the LP Design Space imports a wide variety of file formats. I can generate a file in LB, export it as an image file, and then import and engrave with the LP4. The engrave function is pretty solid.

Have the LP support folks acknowledged the issue with the inconsistent reported firmware versions? That should be something straightforward to validate and acknowledge or otherwise address.

Is there a way to update the firmware outside of the auto-update check?

Hello, I have the same problem as I wrote above. I bought LP4 in the official store on aliexpress on pre-order. And the firmware version in the LB console is exactly the same - V6.5.2. And I can’t update the LP through the LP-app. I wrote to the technical support and send them a link to this topic, but I haven’t receive a clear answer yet. At the present moment I’m using LB just like you - “I can generate a file in LB, export it as an image file, and then import and engrave with the LP4. The engrave function is pretty solid.” The LP works really well, as advertised, with the original software. Firstly I downloaded the trial version of the LB for the test and the LP didn’t work. I found this topic and realized, that I’m not the only one with the same problem. Inspite of knowing the problem, I’ve bought an LB license :slight_smile: the LB program is awesome and I still hope, that everything will work in nearest future :slight_smile:

The LP people have not acknowledged the inconsistent firmware version. There does not appear to be any way to force an update. I’ve asked if there was a way to do this but I have gotten no response. This is only conjecture, but I, because I’m being stonewalled, fear the early distributions of the Kickstarter funded LP4s have a hardware issue that doesn’t allow a firmware update but records that the firmware was updated in the file on the “cloud”. There may not be any fix for the LP4s already shipped.

I found two bugs in the LP4 Windows Design Space software. V2.2.0 does not rotate images correctly some of the time in the 2K resolution, and all of the time in the 4K and 8K resolutions, and the update, V2.2.1 rotates the images just fine but buggers up rotating the text - in both vesions the text and images are rotated correctly on screen but are not engraved correctly. In V2.2.1, the undo function totally destroys the rotated text on screen. V2.2.0 is pretty solid for text, so I use it for text, but for anything with both text and images, I use LB and then import into LP.

Hell everybody,

got LaserPecker 4 with installation tutorial from LP-Homepage. The only thins is, that framing wont work. I tried with “shift” + frame but I didnt see any frame on my workspace. Anybody got same problem?

Newest firmware installed, also manual from LP-Homepage with config files.

Thank you