Layer "Power Min" with GRBL


I’m using Lightburns and I love the simplicity of this software, and the ability to use vector designs and “fill” the shapes.
However, I have an issue with my low power diode laser.

When I’m using the “Fill + Line” mode, the laser doesn’t burn enough the start / end areas to fill (where the laser accelerates / decelerates).
I believe that is due to the fact that the laser power is not linear, or / and the material is not receptive enough to a low power beam.
I tried to change the “$31” setting to set a higher “min spindle speed”, but when I tried to use the laser afterwards, the laser beam was way weaker (I don’t understand why).
I wanted to change the “Power Min” setting on each layer, but the value is fixed (control disabled). Moreover, the value is not the same for each layer, and those values seem to be shared between all my project, per layer (name).

Could you explain to me why this setting cannot be edited ? And why it is shared between my projects ?
Will it help me to fix my issue ? Do you have another way to fix it ?

Best regards,


I’m definitely no expert on this, but would “Overscanning” help you with the problem?

GRBL doesn’t have this level of control - it’s either constant power for the whole cut, or ramped based on speed. DSP controllers, like Ruida, allow setting both a low and high (min/max) power for the ramp, but GRBL has no method for this.

Increasing your acceleration can help with this, and on a normal Line layer there’s an ‘overcut’ option that will got just a little farther around closed shapes, and that would help here too.

The $31 parameter works backwards to what you think it does - it means “what value from the software means zero power on the controller” - it’s used to map RPM ranges for rotary spindles, so you can map the range 3000 to 15000, for example, if you know your spindle won’t run slower than 3000 RPM.

Newer versions of GRBL (1.1h, maybe?) have some additional parameters for the minimum PWM output value, and Smoothieware has a config setting for this too.

It works, even if I would have preferred a more “device configuration” approach.

Too bad that GRBL cannot manage that without reflashing the firmware (I don’t have the current firmware configuration, so I prefer avoid flashing the device).
I didn’t tried changing the acceleration yet, as using the “overscaning” option with the default value did the trick for the current job. I will maybe revisit this solution on some other jobs.

I believed that if the $31 parameter is 1000 and $30 = 10000, the power would have been remapped for this range (so 0% power = 1000 and 100% power = 10000).

I didn’t knew the smoothieboards, and I will document myself as I also own two 3D printers.

Another question: what is the meaning of “min power” on the layer configuration ?



I completely missed that you were missing the start/end of the filled part, not the line part. In that case, yes, overscan is the correct answer - DSP controllers actually do this internally when rastering, because it’s the correct way to handle this and gives the best output quality.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.