LB bridge connection issues

I have a Mac and I have a Pi 4 with Lightburn installed connected to a monitor/keyboard/mouse with an ethernet cable to my laser (Ruida controller), but it won’t connect. I can’t see the Pi network to connect the two. However, when I look at my router connections online, I can see the raspberrypi network is connected to my home wifi. I have reset the laser IP address to I have been trying for well over a month to get my laser up and running and this is the latest stumbling block. Please help!

Does the Ruida indicate it’s lan is ‘on’? Bottom right of the control panel display.

That will tell you if it’s connected to the Pi.

If you can see the Pi and get the IP you can manually configure it.

Did you try that?

Assume you did …


The Lan is on. By if I can see the Pi, where should I be looking? I have not tried that.

Where do you see this? It should give you the IP…

Did you go through the lightburn setup for the Pi bridge?


I saw the raspberrypi by looking at the connected clients on my router’s wifi, my home wifi.

I am going through LB to try to setup the Pi bridge, but it’s not connected yet to find it.

I do have the IP address for the Pi, where do I enter that?

It would help, if you could identify at which step in the setup procedure that isn’t working.


I have gotten to the part of adding my device in LB.

I entered the Pi IP address after I clicked Create Manually for adding devices. It added the Ruida, but when you look at the Laser window in LB it shows Disconnected.

If you right click on the ‘Device’ button, it will attempt a reconnect.

Did you make it to ‘Configure Lightburn Bridge’?


It has never connected to try to reconnect.
No, I didn’t make it to configure LightBurn Bridge.

I have manually added it as a device, OmTech80 and made it the default. That’s as far as I have gotten. When I click Lightburn Bridge, I get the second window and it says to find the Lightburn device, but it doesn’t show in my list of networks.

What do you get when you click on “Lightburn Bridge” button?


and i don’t see the bridge to connect to it

If it’s connected, to your network, skip ahead to the scanning page…?


i have tried that, this is what i get. it gets to this page and nothing happens.

the only place i can see raspberrypi connected is to my home wifi and only via my router client connections, it doesn’t show up anywhere else.

If you can see it there you should be able to see an associated IP address.
Paste that address into your browser and you should see a status dashboard. Post a screenshot of that here.

and also, just fyi

i have hit my limit of replies for a new user for the next 18 hours. if it’s not one thing, it’s another.

You are looking for a wifi bridge correct?

Not using USB in any way?

Just making sure.


correct, i have an ethernet cable connecting my pi and laser.
(i had to create a new account, as a new user, i wasn’t able to reply for the next 18 hours and i don’t have that time to waste.)