Ligfhtburn not recognise MKS DLC32 - GRBL etc does

I just installed a MKS DLC32 for my K40. LaserGRBL recognizes it and controls no problem. Lightburn does not recognize at all… just says “waiting for connection”. Tried multiple usb cables and ports but being the other software’s work ok… why does Lightburn not see it! I purely upgraded to lightburn (to match my other lasers) and they have no issues. & yes windows shows a CH340 device and recognizes it too. MKS board running most recent LASER firmware also.

You set it up in devices?

If you set it up and working with LaserGrbl, then Lightburn should talk to it. You debugged it to between the OS and Lightburn.

I sometimes, for the port use (Choose) then right click the device button, it will find the machine.

I have a DLC32 board and a couple other grbl boards and it connects, no problem…

I rarely hear it’s a protection problem with the os, but you’d have to look at that… I’m a Linux person :grimacing:

:smile_cat:

It will not “find my laser” automatically so manually setup. Com port shows immediately but beyond that no communication

It literally shows the COM port no issue even on changing USB ports, have to add the laser manually as “find my laser” does nothing. I just tried the right click and immediately brought up the port and profile but yet still no communication :face_with_raised_eyebrow:

Quick crazy update… I accidentally clicked one of my other lasers on the same com port… It immediately recognizes the board and tried to home… WTF lol

Do you have a device file for each laser?

:smile_cat:

OK so after I accidentally clicked my other cutters profile in lightburn it has worked ever since. I just copied, renamed the profile then changed all the config to suit. I have another issue now but unrelated so will make another thread

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.