LightBurn 0.9.10 released

9 Likes

Can you explain the z axis changes so I don’t have any unwanted surprises when running the newest software version? “True relative Z moves for Ruida controllers (much safer use of the Z axis)”

If you enable ‘Relative Z moves only’ in the device settings, all Z moves are sent relative to the starting height, and the material height is ignored. The previous versions of LightBurn required you to be connected to the machine when you sent the job, so it could read the current height from the controller, and set the Z moves relative to that value, but that meant if you stored a job on a USB drive it wouldn’t work.

The new method uses true relative moves (move down xx mm / move up xx mm) instead of absolute moves, so if you adjust your focus height up a little, for example, the Z moves will automatically adjust upwards with it.

With the camera engine being redesigned I notice it specifically mentions windows computers. Are Mac computers supported with a camera function also? I am thinking of switching to a Mac and definitely want to take advantage of a camera.

LightBurn on Mac did not have the same issues requiring the new camera elements. We have many Mac users successfully using LightBurn with a camera integrated into their workflows. Switch away! :wink:

thank you Oz

thank you all the beta testers

this is wonderful news.

multi node selection.
i’m in heaven !!!

well done to you all.

1 Like

Thank you. going through the list of new features made my laser tube exited more than ever. First thing i tried was checking preview thumbnails. opened a project, re-saved it but the icons are the same old red dragons.

Win10/64.

thanks for the multiple node selects,how does one use the art library? as the import is greyed out and I dont have any .Ibart files to load.

Have you tested some different webcams with this new version?
And if so, do you have a list of working cams.?
I was very exited to read that this version will now support normal webcams, so I hooked up my nice Logitech C920 Pro. But NOPE! It’s still not working under Lightburn.
The best cam I’ve used so far is still the Mobius actioncam!

Create a new library first, then you can import files, or select stuff in the edit window and add it to the library. Each library you create is a file on disk, and you can unload them when you’re not using them, and then load them again later. For example, you could have a library of Christmas stuff that you only use around the holiday.

It’s only for Windows 8 and up - Windows 7 still uses the older library because it doesn’t the Windows Media Engine used to access the cameras. If you have Windows 8 or later it should work, but it’s possible you need a media pack installed. (https://www.microsoft.com/en-us/download/details.aspx?id=16546)

I have a Logitech C910 that works perfectly, and I’ve tested all the other cameras I have on hand - a couple of ours, a few ELP cameras from Amazon, and a couple small endoscope cameras. All of them worked as expected.

I’m running Windows 10, so it should be no problem…?
But I have no luck with the camera. It works fine in all other applications, just not Lightburn.
I checked in the Windows setup to be sure camera was allowed for all applications.
But still no functionality in LB. :frowning:

There are lots of different versions of Windows 10, and not all come with the media framework used (Windows 10 N I think is missing it). Check to make sure you have no anti-virus software running that’s blocking it. Sometimes it’s necessary to reboot the system.

@LightBurn updated today i’ve got some bugs with new version, where laser stops and pauses between tasks, i’ve attached video showing problem, is it possible to revert back to previous version,
Thanks for the continuous work and upgrade’s though,
Video here

Is there a way to turn off the sanity check? I have an HD lens and usually work at 600DPI and every time I go into the setting I have to click the sanity check to continue.

Ok, so looked at the video and am going to make a wild guess, but before I do, I want to offer that the dimming of the Image was my personal request. :wink: I wanted images to dim when the output is ticked off so it behaves the same as all other objects when output is ticked off. This is a new addition to this release, so you can blame or thank me as you see fit.

Now to my guess. Do you by chance, happen to have the ‘Cut Through’ mode ticked ON (green) for the layers that have this delay?

2 Likes

@Rick hiya Rick i do not have that option, in my cut settings editor, i only have start pause time and end pause time, no { enable cut through mode at all } although my start and end pause time on the red was at 50ms, which i have now changed to 0, but this was not set by myself, so maybe has always been the same, but i would think 50ms is not equivalent to 2mins,
Quick screen cast for you to peruse, Rick
Click here

Im using Logitech C615 on Win 10 Since the update it works perfectly. Full resolution, very clear.

Yes, you are seeing the difference in the LightBurn UI. I presented my Ruida Profile Cut Settings as that is what I was using at the time. You did not offer what you are using in your first post.

Additionally, I said it was a guess. :slight_smile:

Are you saying that your cut settings for these layers had a 50ms start and stop pause? What was the result after you changed the cut setting and removed the delay?

hi there I’ve just upgrade the software and I have some issues. I try to send letter “M” to my laser machine but it takes it like an upside-down 3. Same with letter “A” it takes it as “PM”. before upgrade all worked! I think that there are more issues with the same text format but I haven’t check them yet.
[WhatsApp Image 2020-03-16 at 17.53.43 (1)|690x335](upload://mZjHbwsEeD8l47gRe

1QdF9UoVyr.jpeg) d fine. thx for your help.