Lightburn 0.9.21 doesn’t work any ideas?

I have a ruida controller and am running Mac OS 11.2.3 and when I try to start a burn the laser does not move or fire the run time does start counting on the ruida when I hit the stop it will move back home (if the laser is not home) and beep like normal saying to say it’s done I can frame and move the laser around with it just won’t burn anything I reinstalled 0.9.20 and it works just fine (I have both versions installed currently but nothing I do will get .21 to fire)

How do you connect to the laser? (USB, ethernet?). Are you using the Big Sur version, or just the generic “MacOS” version?

You’re the 2nd person I know of to have this issue, and I haven’t figured out any sort of cause yet.

I’m on the Big Sur or later download and am connected with usb

Same issue. Macos High seirra. 10.13.6. Was working before I upgrade to 0.9.21

Can you try installing this driver?

MacOS has always been troublesome with USB connections on Ruida controllers - MacOS ships with a driver than conflicts with the one used by Ruida.

Downgraded to 0.9.20 and it works again.

Im having issues too after the update. I have a Ruida on Mac Os El Capitan 10.11.6. I usually frame before starting a burning. Frame works fine but right after framing when I press start, there is no reaction at all.

On the other hand, if I start a burning directly without framing, everything works fine.

I will probably have to go back to 0.9.20 for the time being.

Ok I installed it and now it’s working with .21 so I see in the release notes that you changed the way the computers talk with the controllers you might need to bundle this driver for Mac with the Mac software

I got 19 mins into a burn and it stopped!! So no that driver did not fully fix the issue it got it some what working but not fully

What is it that you’re running? (a single image, multiple vector shapes, etc…?)

A image I did the same burn in 9.20 and it worked just fine

What controller (and model number) are you using?

On the controller it says Ruida 6442G-B both versions of lightburn just says 644xg.

Negative ghost rider it stopped at like 85% complete and then when I tried to start a different project it wouldn’t start it would frame but now will not burn anything but I can still burn with .20 would that driver you had me install be causing a issue? I feel like it is sending the file to ruida in a corrupt way cause it stops burning the timer keeps counting even restarting the controller doesn’t always clear it I had to restart the controller 3 times to get it to let me burn with .20

I just tried the newest version you had in this thread, and it’s not working at all now. I can’t even frame the piece.

The driver shouldn’t be the issue. A change to how Z moves are embedded in the job file caused issues with some Ruida controllers.

Your profile says “Mini Gerbil” - Are you using a Ruida with MacOS, or not? That’s what this thread is.

Apparently, I need to change my profile, I got a new laser, and have been working with it for about 2 months now.

… and it is a … Ruida? Model number? You’re using MacOS?