LightBurn absolute coordinates stopped working with xTool D1 Pro

I’ve used LB with my xTool D1 Pro before, but now it’s not working correctly. The issue may be related to upgrading to a new MacBook and having to reinstall the xTool driver. Unfortunately the problem doesn’t occur with the xTool Creative Space software, so I can’t expect help from xTool support.
The problem is:
Using absolute coordinates, when I create or load a project and click “Frame,” everything looks good. But when I click Start, the laser head goes to the home position and sits there with the fan running and the laser off.
When I use relative coordinates (“start from” set to “current position”), the job is engraved or cut as expected.
So this isn’t a huge problem, but it’s weird and I don’t like not being able to use absolute coords. I’ve seen other users on this forum describe similar problems, but none where a solution was included in the thread.

Setup a new device by importing this xTool-D1ProV3.lbdev (3.9 KB)

Come back with more questions.

Yup; did that. It got me connected to the xTool, but with the issue described.

Did you use a PC to update the Firmware in the xTool D1 Pro?
If so, we’re attempting to capture undisclosed changes on their end.

With your xTool D1 Pro connected to your MacBook and LightBurn up and running, Please select and copy the first few lines from the Console window in LightBurn and paste them into a reply here.

Grbl (the original open source protocol) had a troubleshooting tool that shares how the coordinate systems are set up. I think xTool disabled it on the xTool D1 Pro but it may be worth testing.

In the Console window in LightBurn please type the following:
then press Enter (or return).
Please let me know how the xTool D1 Pro responds to requesting this report.

I used xTool’s XCS software running on a Mac to update the firmware. Not sure when I did that relative to when this problem appeared.

Waiting for connection…


M116 X0 Y20


M116 X0 Y20


M100 xTool D1Pro





start_home x

left limit trigged

start_home y

up limit trigged





This topic was automatically closed after 30 days. New replies are no longer allowed.