Lightburn and Cronos board compatibility

Will lightburn control my Cronos board diode laser?

If it’s running GRBL firmware, yes, it should. The simplest way to find out would be to download and use the trial.

Thanks for your input, I will try that when I get back to my machine.
I do have a licensed version of light burn.

This seems to be advertised as a 2-axis GRBL controller so it should work.

Yes, it works great, except I can’t get lightburn to do PWM with it , were as I can do PWM with a different software “ laser engraver LE” on this machine.

That’s odd.

Some things to check:

  1. Make sure you’re correctly wired for PWM. Make sure the 12V +, -, and TTL pins correlate to those on the laser module.
  2. Check value of $30, $31, and $32 in Edit->Machine Settings. What are these?
  3. Make sure that S Value Max in Edit->Device Settings equals the value of $30. For your machine this should be 255 for both but please confirm.
  4. Push Devices button in Laser window. Then click once on the name of your laser. What Device type is shown on the bottom left of that window?

Separately, can you run these commands in Console and return output?


I have played around with different speed and DPI settings and can’t seem to get what I expect.

Do you have any suggestions?


Upon further inspection, I noticed that this.


In this case, looks like $32 is supposed to be false

Does this mean my cronos Board is not running PWM?

Another observation, when I am running the lightburn software the laser is definitely shutting on and off as it makes a horizontal pass.

On the other software, “laser engraver“ the laser beam stays on constantly as it makes a horizontal pass. This results in a smoother, more natural looking image than what I’m getting on the lightburn.

I sure wish I could understand what setting I have wrong on the Lightburn.


There should be no type called “GRBL Cronos”. This may be the name of your laser, not the device type. Make sure you’re looking at the bottom left of that window after clicking once on the name of your laser. If uncertain, can you take a screenshot of Devices window with laser name selected?

This should be on for any modern version of GRBL. 1.1f or newer. Yours is 1.1f according to the welcome message. It’s odd that it won’t stay toggled on.

Your screenshot do not include the full output from the commands requested? Can you simply copy and paste the text output in Console? Only $$ is required since I can see the output of $I.

How are you determining that PWM is not working? If you use Fire button in Move window and increase power, does the laser light get brighter?

Are you writing back the changes once toggled? If not, that’s likely why it’s not staying on.

Here is my move window and I don’t see any fire button.

I don’t believe the PWM is working, because I’m not getting a proper image, and with the other software running the same image, the laser stays on all the time, whereas in lightburn, as it flashes on and off as it traverses horizontally

Then you likely need to enable the Fire button in Edit->Device Settings.

Try running a material test at different power levels. If you can get different power levels at the same speed then that means that power modulation is working.

If you can get variable power with Fire button that also indicates that PWM is working.

I can get variable power with the “fire button” , so it sounds like I am getting the PWM.

If that’s the case, I simply need to play around with the proper settings.

The $32 is now staying as “true”

Thanks for sticking with me and getting me squared away on this.

I am really liking the lightburn program and I’m impressed that I can take the Gcode that it generates and use it on my CNC milling machine running Mach4, without any modifications which is a big plus for me.

Here is the “$$” — does this look normal?






































I don’t see any big oddities especially with relation to PWM. And with $32=1 you’re good to go there.

One thing you do want to make sure is that you’re using the “GRBL” profile, not “GRBL-M3”. If you use GRBL-M3 you lose some of the benefit of all the trouble you went through getting $32=1.

Will do, thanks again.